Cleanup local patchset.
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r3.2"
9
10 inherit task 
11
12 RDEPENDS_${PN} = "\
13         task-base-extended \
14         task-proper-tools \
15         pandora-firmware \
16         pandora-wifi pandora-wifi-tools \
17         omap3-deviceid \        
18         omap3-sgx-modules devmem2 libgles-omap3 \
19         sudo \
20         lsof \
21         gnome-volume-manager \
22         libwiimote \
23         libsdl-gfx \
24         nfs-utils nfs-utils-client \
25         i2c-tools \
26         tslib tslib-tests tslib-calibrate pointercal \
27         bash \
28         bzip2 \
29         psplash \
30         fbgrab fbset fbset-modes \
31         portmap \
32         fuse sshfs-fuse ntfs-3g \
33         file \
34         aufs aufs-tools \
35         socat \
36         strace \
37         python-pygame \
38         ksymoops \
39         kexec-tools \
40         minicom \
41         nano \
42         alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
43         openssh-scp \
44         openssh-ssh \
45         bluez4 bluez-hcidump bluez-utils \
46         wireless-tools \
47         rdesktop \
48         zip \
49         openssh-scp openssh-ssh \
50         mplayer \
51         networkmanager netm-cli \
52 "
53
54 # Make sure we install all kernel modules with the Pandora images
55 RRECOMMENDS_${PN} += "kernel-modules"
56
57 PACKAGE_ARCH = "${MACHINE_ARCH}"
58 RRECOMMENDS_${PN}_append_armv7a = " omapfbplay"