task-pandora-core: switch to split libgles-omap3 packages
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r43"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35 #  pandora-firmware \
36 #  wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \
52   audiofile \
53 "
54 OPENGLES = " \
55   omap3-sgx-modules devmem2 \
56   libgles-omap3-es23 \
57   libgles-omap3-dm3730 \
58 #  libgles-omap3-rawdemos \
59 "
60
61 PAM = " \
62   libpam \
63   libpam-meta \
64 "
65
66 PANDORA_LIBS = " \
67   pandora-libpnd lsof \
68   omap3-deviceid \
69   pandora-skel \
70   pandora-state \
71   pandora-usbhost \
72 "
73
74 SUDO = " \
75   sudo sudo-enable-wheel-group \ 
76   pandora-sudoers \
77 "
78
79 SSH = " \
80   openssh-scp \
81   openssh-ssh \
82 "
83
84 TOUCHSCREEN = " \
85   tslib tslib-tests tslib-calibrate pointercal \
86 "
87
88 FS_SUPPORT = " \
89 #  nfs-utils \
90   nfs-utils-client \
91   fuse fuse-utils \
92   sshfs-fuse gmailfs curlftpfs \
93   ntfs-3g \
94   squashfs-tools \
95 "
96
97 EXTRA_TOOLS = " \
98   avahi \
99   fbgrab fbset fbset-modes \
100   portmap \
101   file \
102   socat \
103   strace \
104   screen \
105   rsync \
106   unrar \
107   ksymoops \
108   kexec-tools \
109   zip \        
110   gzip \
111   bash \
112   bzip2 \  
113   minicom \
114   nano \
115   gdb \
116   sessreg \
117   lua5.1 \
118   tzdata \
119 "
120
121 # Add extra util-linux-ng utils to image. 
122 # TODO: Fix util-linux-ng to meta depend on all subpackages.
123 UTIL_LINUX_NG_EXTRAS = " \
124   util-linux-ng-losetup util-linux-ng-mountall \
125   util-linux-ng-swaponoff \
126 "
127
128 # sysvinit-* used to not be needed, but after adding
129 # recipes/sysvinit/sysvinit/omap3-pandora/*
130 # they are no longer included automatically?
131 SYSVINIT = " \
132   sysvinit-inittab \
133   sysvinit-sulogin \
134   sysvinit-utils \
135 "
136
137 RDEPENDS_${PN} = "\
138   task-base-extended \
139   task-proper-tools \
140   ${SYSVINIT} \
141   ${AUFS} \
142   ${BOOST} \
143   ${WIRELESS} \
144   ${BLUETOOTH} \  
145   ${BOOT} \
146   ${MEDIA_LIBS} \
147   ${OPENGLES} \
148   ${PANDORA_LIBS} \
149   ${PAM} \  
150   ${SSH} \
151   ${SUDO} \
152   ${TOUCHSCREEN} \
153   ${FS_SUPPORT} \
154   ${EXTRA_TOOLS} \
155   ${UTIL_LINUX_NG_EXTRAS} \
156 #        packagekit \
157   python-pygame \
158   python-misc \
159   python-modules \
160   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
161   openal-soft \
162   rdesktop \
163   \
164 #  angstrom-zeroconf-audio \
165   angstrom-led-config \ 
166   ntpdate \ 
167   omap3-pandora-kernel2 \
168 "
169
170 # Make sure we install all kernel modules with the Pandora images
171 RRECOMMENDS_${PN} += "kernel-modules"
172
173 PACKAGE_ARCH = "${MACHINE_ARCH}"