task-pandora-core: make sure blkid is included
[openpandora.oe.git] / recipes / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps and libs in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r47"
9
10 inherit task 
11
12 AUFS = " \
13   aufs2-util \
14 "
15
16 BLUETOOTH = " \
17   blueprobe \
18   bluez4 gst-plugin-bluez \
19   libsndfile1 libasound-module-bluez \
20 "
21
22 # Package up the boot scripts and bootchart to help us work to drop the startup time.
23 BOOT = " \
24   pandora-uboot-scripts \
25   bootchart \
26   mtd-utils \
27 "
28
29 # Package BOOST libs so people can use them in apps. It will pull in the RRECOMENDS.
30 BOOST = " \
31   boost \
32 "
33
34 WIRELESS = " \
35 #  pandora-firmware \
36 #  wl1251-modules \
37 #  pandora-wifi pandora-wifi-tools \
38   wireless-tools \
39   wpa-supplicant \  
40   networkmanager netm-cli \
41 "
42
43 MEDIA_LIBS = " \
44   libmodplug \
45   libsdl-x11 libsdl-mixer libsdl-image \
46   libsdl-gfx libsdl-net libsdl-ttf \
47   libpng libpng12 libpng3 \
48   faad2 \
49   mikmod \
50   speex \  
51   flac \
52   audiofile \
53 "
54 OPENGLES = " \
55   omap3-sgx-modules devmem2 \
56   libgles-omap3-es23 \
57   libgles-omap3-dm3730 \
58 #  libgles-omap3-rawdemos \
59 "
60
61 PAM = " \
62   libpam \
63   libpam-meta \
64 "
65
66 PANDORA_LIBS = " \
67   pandora-libpnd \
68   pandora-libpnd-pndnotifyd pandora-libpnd-pndevmapperd \
69   lsof \
70   omap3-deviceid \
71   pandora-skel \
72   pandora-state \
73   pandora-usbhost \
74 "
75
76 SUDO = " \
77   sudo sudo-enable-wheel-group \ 
78   pandora-sudoers \
79 "
80
81 SSH = " \
82   openssh-scp \
83   openssh-ssh \
84 "
85
86 TOUCHSCREEN = " \
87   tslib tslib-tests tslib-calibrate pointercal \
88 "
89
90 FS_SUPPORT = " \
91 #  nfs-utils \
92   nfs-utils-client \
93   fuse fuse-utils \
94   sshfs-fuse gmailfs curlftpfs \
95   ntfs-3g \
96   squashfs-tools \
97 "
98
99 EXTRA_TOOLS = " \
100   avahi \
101   fbgrab fbset fbset-modes \
102   portmap \
103   file \
104   socat \
105   strace \
106   screen \
107   rsync \
108   unrar \
109   ksymoops \
110   kexec-tools \
111   zip \        
112   gzip \
113   bash \
114   bzip2 \  
115   minicom \
116   nano \
117   gdb \
118   sessreg \
119   lua5.1 \
120   tzdata \
121   ca-certificates \
122 "
123
124 # Add extra util-linux-ng utils to image. 
125 # TODO: Fix util-linux-ng to meta depend on all subpackages.
126 UTIL_LINUX_NG_EXTRAS = " \
127   util-linux-ng-losetup \
128   util-linux-ng-swaponoff \
129   util-linux-ng-blkid \
130   util-linux-ng-fsck \
131 "
132
133 # sysvinit-* used to not be needed, but after adding
134 # recipes/sysvinit/sysvinit/omap3-pandora/*
135 # they are no longer included automatically?
136 SYSVINIT = " \
137   sysvinit-inittab \
138   sysvinit-sulogin \
139   sysvinit-utils \
140 "
141
142 RDEPENDS_${PN} = "\
143   task-base-extended \
144   task-proper-tools \
145   ${SYSVINIT} \
146   ${AUFS} \
147   ${BOOST} \
148   ${WIRELESS} \
149   ${BLUETOOTH} \  
150   ${BOOT} \
151   ${MEDIA_LIBS} \
152   ${OPENGLES} \
153   ${PANDORA_LIBS} \
154   ${PAM} \  
155   ${SSH} \
156   ${SUDO} \
157   ${TOUCHSCREEN} \
158   ${FS_SUPPORT} \
159   ${EXTRA_TOOLS} \
160   ${UTIL_LINUX_NG_EXTRAS} \
161 #        packagekit \
162   python-pygame \
163   python-misc \
164   python-modules \
165   alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
166   openal-soft \
167   rdesktop \
168   \
169 #  angstrom-zeroconf-audio \
170   angstrom-led-config \ 
171   ntpdate \ 
172   omap3-pandora-kernel2 \
173 "
174
175 # Make sure we install all kernel modules with the Pandora images
176 RRECOMMENDS_${PN} += "kernel-modules"
177
178 PACKAGE_ARCH = "${MACHINE_ARCH}"