op_datetime.sh: Fixed screen blanking when changing time
[openpandora.oe.git] / recipes / pandora-system / pandora-wifi_git.bb
1 DESCRIPTION = "Kernel drivers for the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
2 LICENSE = "GPLv2"
3
4 # Check the include for the source location/GIT SRCREV etc.
5 require pandora-wifi.inc
6
7 SRC_URI += " \
8         file://rc.tiwifi \
9 #       file://0001-Initial-work-on-WEXT-support.patch;patch=1 \
10 #       file://0002-More-cleanup-work-on-WEXT.-Now-at-the-point-that-use.patch;patch=1 \
11 #       file://0003-Oooops-now-lets-try-something-that-compiles.patch;patch=1 \
12 #       file://0004-Clean-up-to-use-IW_RETRY_LONG-and-IW_RETRY_SHORT.patch;patch=1 \
13 #       file://0005-Fix-ooops-I-really-don-t-want-funky-private-features.patch;patch=1 \
14         file://0001-Fix-in-wlan_cu-makefile-to-make-OUTPUT_DIR-not-fixed.patch;patch=1 \
15         file://0002-Add-in-the-start-of-wireless-extensions-support-ioct.patch;patch=1 \
16         file://0003-Merge-in-latest-wireless-ext.-hacks.patch;patch=1 \
17         file://0004-Default-to-DEBUG-Y-for-testing.patch;patch=1 \
18         file://0005-More-WEXT-cleanup.patch;patch=1 \   
19         file://0006-Add-back-in-missing-header-o.patch;patch=1 \
20         file://0007-Add-iw_ioctl.h-header.patch;patch=1 \
21         file://0008-Update-Wireless-EXT-with-test-code.patch;patch=1 \
22 "
23
24 inherit update-rc.d
25
26 INITSCRIPT_NAME = "tiwifi-init"
27 INITSCRIPT_PARAMS = "stop 40 0 1 6 ."
28
29 do_compile_prepend() {
30           cd ${S}/sta_dk_4_0_4_32/
31 }
32
33 do_install() {
34           cd ${S}/sta_dk_4_0_4_32/
35           mkdir -p ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan
36           cp ${S}/sta_dk_4_0_4_32/*.ko ${D}/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan
37           install -d ${D}${sysconfdir}/init.d/
38           cp -pP ${WORKDIR}/rc.tiwifi ${D}${sysconfdir}/init.d/tiwifi-init
39           cp -pP ${S}/sta_dk_4_0_4_32/fw/tiwlan.ini ${D}${sysconfdir}/tiwlan.ini         
40 }
41
42 FILES_${PN} += "/lib/modules/${KERNEL_VERSION}/kernel/drivers/net/wireless/tiwlan/*.ko.*"