pandora-scripts.bb: Fixed missing tvout-profiles.conf
[openpandora.oe.git] / recipes / pandora-system / pandora-uboot-scripts.bb
1 DESCRIPTION = "Helper uboot boot scripts for the OpenPandora"
2
3 DEPENDS = "u-boot-mkimage-native"
4
5 SRC_URI = "file://boot*"
6
7 PR = "r2"
8
9 do_configure() {
10         cp ${WORKDIR}/boot* ${S}
11 }
12
13 do_compile() {
14         for i in boot* ; do
15                 uboot-mkimage -A ${TARGET_ARCH} -O linux -T script -C none -a 0 -e 0 -n "OpenPandora $i" -d $i $i.scr
16         done
17 }
18
19 do_install() {
20         install -d ${D}${datadir}/u-boot-scripts
21         for i in *.scr ; do
22                 install -m 0644 $i ${D}${datadir}/u-boot-scripts
23         done
24 }
25
26 FILES_${PN} += "${datadir}"
27
28 addtask deploy before do_package after do_install
29
30 do_deploy() {
31         install -d ${DEPLOY_DIR_IMAGE}
32         for i in *.scr ; do
33                 cp $i ${DEPLOY_DIR_IMAGE}
34                 package_stagefile_shell ${DEPLOY_DIR_IMAGE}/$i
35         done
36 }
37
38 PACKAGE_ARCH = "${MACHINE_ARCH}"