pandora-scripts: add scaler fir coef script and data
[openpandora.oe.git] / recipes / pandora-system / pandora-state.bb
1 DESCRIPTION = "Save and restore some specific Pandora settings on shutdown / startup"
2 LICENSE = "GPLv2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 PR = "r5"
7 inherit update-rc.d
8
9 INITSCRIPT_NAME = "pandora-state"
10 INITSCRIPT_PARAMS = "start 39 S . stop 31 0 1 6 ."
11
12 SRC_URI = " \
13           file://rc.pandora-state \
14           file://gamma.state \
15           file://brightness.state \
16           file://nubs.state \
17           file://dirty_expire_centisecs \
18 "
19
20 do_install() {
21           install -d ${D}${sysconfdir}/init.d/
22           install -m 0755 ${WORKDIR}/rc.pandora-state ${D}${sysconfdir}/init.d/pandora-state
23           install -d ${D}${sysconfdir}/pandora/conf/
24           install -m 0644 ${WORKDIR}/gamma.state ${D}${sysconfdir}/pandora/conf/gamma.state
25           install -m 0644 ${WORKDIR}/brightness.state ${D}${sysconfdir}/pandora/conf/brightness.state
26           install -m 0644 ${WORKDIR}/nubs.state ${D}${sysconfdir}/pandora/conf/nubs.state
27           install -m 0644 ${WORKDIR}/dirty_expire_centisecs ${D}${sysconfdir}/pandora/conf/dirty_expire_centisecs
28 }
29
30 PACKAGE_ARCH = "${MACHINE_ARCH}"
31
32 FILES_${PN} += "${prefix} ${datadir}"