f24f54fb6e6f6d3a22f52d0ff7c7cc9b77f629e5
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
1 DESCRIPTION = "Default 'new user' files on the OpenPandora."
2
3 COMPATIBLE_MACHINE = "omap3-pandora"
4
5 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
6 RDEPENDS = "shadow"
7
8 PR = "r1"
9
10 SRC_URI = " \
11   file://.xinitrc \     
12   file://bashrc \
13   file://profile \
14   file://mplayconfig \
15   file://pam_environment \
16   file://xsettings.xml \
17   file://pndXmodmap \
18   file://asoundrc \
19 "
20
21 # xsettings.xml is a hack until I can figure out why XDG configs are not setting the icon theme for Xfce/GTK+
22
23 do_install() {
24   install -d ${D}${sysconfdir}/skel/
25   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
26   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
27   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
28   install -m 0644 ${WORKDIR}/pam_environment ${D}${sysconfdir}/skel/.pam_environment
29   install -m 0644 ${WORKDIR}/pndXmodmap ${D}${sysconfdir}/skel/.pndXmodmap
30   install -m 0644 ${WORKDIR}/asoundrc ${D}${sysconfdir}/skel/.asoundrc
31   
32   install -d ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml
33   install -m 0644 ${WORKDIR}/xsettings.xml ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
34   
35   install -d ${D}${sysconfdir}/skel/.mplayer/
36   install -m 0644 ${WORKDIR}/mplayconfig ${D}${sysconfdir}/skel/.mplayer/config
37 }
38
39 PACKAGE_ARCH = "${MACHINE_ARCH}"
40
41 FILES_${PN} += "${prefix} ${datadir}"