pandora-libpnd: Bump SRCREV to include the keymapper daemon and start to rejig init...
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
1 DESCRIPTION = "Default 'new user' files on the OpenPandora."
2
3 COMPATIBLE_MACHINE = "omap3-pandora"
4
5 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
6 RDEPENDS = "shadow"
7
8 PR = "r2"
9
10 SRC_URI = " \
11   file://.xinitrc \     
12   file://bashrc \
13   file://profile \
14   file://mplayconfig \
15 "
16
17 do_install() {
18   install -d ${D}${sysconfdir}/skel/
19   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/
20   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
21   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
22
23   install -d ${D}${sysconfdir}/skel/.mplayer/
24   install -m 0644 ${WORKDIR}/mplayconfig ${D}${sysconfdir}/skel/.mplayer/config
25 }
26
27 PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29 FILES_${PN} += "${prefix} ${datadir}"