pandora-scripts: Moved scripts from libpnd-GIT to a proper place :)
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
1 DESCRIPTION = "Default 'new user' files on the OpenPandora."
2
3 COMPATIBLE_MACHINE = "omap3-pandora"
4
5 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
6 RDEPENDS = "shadow"
7
8 PR = "r5"
9
10 SRC_URI = " \
11   file://.xinitrc \     
12   file://bashrc \
13   file://profile \
14   file://mplayconfig \
15   file://pam_environment \
16   file://xsettings.xml \
17   file://pndXmodmap \
18   file://asoundrc \
19   file://vimrc \
20 #  file://op_btenabled \
21 "
22
23 # xsettings.xml is a hack until I can figure out why XDG configs are not setting the icon theme for Xfce/GTK+
24
25 do_install() {
26   install -d ${D}${sysconfdir}/skel/
27   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
28   install -m 0644 ${WORKDIR}/vimrc ${D}${sysconfdir}/skel/.vimrc
29   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
30   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
31   install -m 0644 ${WORKDIR}/pam_environment ${D}${sysconfdir}/skel/.pam_environment
32   install -m 0644 ${WORKDIR}/pndXmodmap ${D}${sysconfdir}/skel/.pndXmodmap
33   install -m 0644 ${WORKDIR}/asoundrc ${D}${sysconfdir}/skel/.asoundrc
34 #  install -m 0644 ${WORKDIR}/op_btenabled ${D}${sysconfdir}/skel/.op_btenabled
35   
36   install -d ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml
37   install -m 0644 ${WORKDIR}/xsettings.xml ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
38   
39   install -d ${D}${sysconfdir}/skel/.mplayer/
40   install -m 0644 ${WORKDIR}/mplayconfig ${D}${sysconfdir}/skel/.mplayer/config
41 }
42
43 PACKAGE_ARCH = "${MACHINE_ARCH}"
44
45 FILES_${PN} += "${prefix} ${datadir}"