omap3-pandora-kernel: bump
[openpandora.oe.git] / recipes / pandora-system / pandora-skel.bb
1 DESCRIPTION = "Default 'new user' files on the OpenPandora."
2
3 COMPATIBLE_MACHINE = "omap3-pandora"
4
5 # /etc/skel is used by Shadow's useradd so you really have that installed for this to make sense ;)
6 RDEPENDS = "shadow"
7
8 PR = "r12"
9
10 SRC_URI = " \
11   file://.xinitrc \     
12   file://bashrc \
13   file://profile \
14   file://mplayconfig \
15   file://pam_environment \
16   file://xsettings.xml \
17   file://pndXmodmap \
18   file://asoundrc \
19   file://vimrc \
20   file://fuse \
21   file://snd-pcm-oss \
22 #  file://op_btenabled \
23 "
24
25 # xsettings.xml is a hack until I can figure out why XDG configs are not setting the icon theme for Xfce/GTK+
26
27 do_install() {
28   install -d ${D}${sysconfdir}/skel/
29   install -d ${D}${sysconfdir}/skel/Desktop
30   install -d ${D}${sysconfdir}/modutils/
31   install -m 0644 ${WORKDIR}/.xinitrc ${D}${sysconfdir}/skel/.xinitrc
32   install -m 0644 ${WORKDIR}/vimrc ${D}${sysconfdir}/skel/.vimrc
33   install -m 0644 ${WORKDIR}/bashrc ${D}${sysconfdir}/skel/.bashrc
34   install -m 0644 ${WORKDIR}/profile ${D}${sysconfdir}/skel/.profile
35   install -m 0644 ${WORKDIR}/pam_environment ${D}${sysconfdir}/skel/.pam_environment
36   install -m 0644 ${WORKDIR}/pndXmodmap ${D}${sysconfdir}/skel/.pndXmodmap
37   install -m 0644 ${WORKDIR}/asoundrc ${D}${sysconfdir}/skel/.asoundrc
38   install -m 0644 ${WORKDIR}/fuse ${D}${sysconfdir}/modutils/fuse
39   install -m 0644 ${WORKDIR}/snd-pcm-oss ${D}${sysconfdir}/modutils/snd-pcm-oss
40 #  install -m 0644 ${WORKDIR}/op_btenabled ${D}${sysconfdir}/skel/.op_btenabled
41   
42   install -d ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml
43   install -m 0644 ${WORKDIR}/xsettings.xml ${D}${sysconfdir}/skel/Applications/Settings/xfce4/xfconf/xfce-perchannel-xml/xsettings.xml
44   
45   install -d ${D}${sysconfdir}/skel/.mplayer/
46   install -m 0644 ${WORKDIR}/mplayconfig ${D}${sysconfdir}/skel/.mplayer/config
47 }
48
49 PACKAGE_ARCH = "${MACHINE_ARCH}"
50
51 FILES_${PN} += "${prefix} ${datadir}"