rtl8192u-module: support more devices
[openpandora.oe.git] / recipes / pandora-system / pandora-set-root-password.bb
1 DESCRIPTION = "Set the root password."
2 SUMMARY = "On installation you will be prompted to set a root password. With \
3 this password you can then log into the machine."
4 LICENSE = "GPL"
5 DEPENDS = "gtk+"
6 PKG_TAGS_${PN} = "group::programming alias::Root_Password"
7
8 SRC_URI = "svn://svn.openmoko.org/developers/zecke/;module=root-password;proto=http"
9 S = "${WORKDIR}/root-password"
10 PV = "1.0+svnr${SRCREV}"
11 PE = "1"
12 PR = "r1"
13
14 do_compile () {
15     cd ${S}
16     oe_runmake
17 }
18
19 do_install() {
20     install -d ${D}/${sbindir}
21     install -m 0755 ${S}/root-password ${D}/${sbindir}/${PN}
22 }
23
24 pkg_postinst_${PN} () {
25     # assume we use display 0
26     DISPLAY=:0 ${sbindir}/${PN}
27 }