pandora-scripts: Add a few more scripts. Bluetooth one needs more work.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r4"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.desktop \          
16           file://op_wifi.sh \
17           file://op_wifi.desktop \          
18           file://op_bluetooth.sh \
19           file://op_bluetooth.desktop \
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22 "
23
24 do_install() {
25           install -d ${D}${prefix}/pandora/scripts/
26           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
27           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
28           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
29           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/          
30           install -d ${D}${datadir}/applications/
31           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
32           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
33           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
34           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
35 }
36
37 PACKAGE_ARCH = "${MACHINE_ARCH}"
38
39 FILES_${PN} += "${prefix} ${datadir}"