pandora-scripts: Add latest scripts to set and switch the default GUI.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r5"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.desktop \          
16           file://op_wifi.sh \
17           file://op_wifi.desktop \          
18           file://op_bluetooth.sh \
19           file://op_bluetooth.desktop \
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22           file://op_switchgui.sh \
23           file://op_switchgui.desktop \
24           file://startnetbooklauncher \
25 "
26
27 do_install() {
28           install -d ${D}${prefix}/pandora/scripts/
29           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
30           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
31           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
32           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
33           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
34           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
35           
36           install -d ${D}${datadir}/applications/
37           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
38           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
39           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
40           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
41           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
42           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
43
44           install -d ${D}${bindir}/
45           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
46 }
47
48 PACKAGE_ARCH = "${MACHINE_ARCH}"
49
50 FILES_${PN} += "${prefix} ${datadir}"