Merge branch 'master' of git://git.openpandora.org/openpandora.oe
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r10"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.desktop \          
15           file://op_wifi.sh \
16           file://op_wifi.desktop \          
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22           file://op_switchgui.sh \
23           file://op_switchgui.desktop \
24           file://startnetbooklauncher \
25           file://startmmenu \          
26           file://op_calibrate.sh \
27           file://op_calibrate.desktop \
28           file://op_datetime.sh \
29           file://op_datetime.desktop \
30           file://gui.conf \
31 "
32
33 do_install() {
34           install -d ${D}${prefix}/pandora/scripts/
35           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
36           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
37           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
38           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
39           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
40           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
41           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
42           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
43           
44           install -d ${D}${datadir}/applications/
45           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
46           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
47           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
48           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
49           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
50           install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
51           install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
52           
53           install -d ${D}${sysconfdir}/xdg/autostart/
54           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
55
56           install -d ${D}${sysconfdir}/pandora/conf/
57           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
58
59           install -d ${D}${bindir}/
60           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
61           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
62 }
63
64 PACKAGE_ARCH = "${MACHINE_ARCH}"
65
66 FILES_${PN} += "${prefix} ${datadir}"