pandora-scripts: Added the PND, commented out .desktop-files for the scripts that...
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r16"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13 #          file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15 #          file://op_cpuspeed.desktop \          
16           file://op_wifi.sh \
17           file://op_wifi.desktop \          
18           file://op_bluetooth.sh \
19           file://op_bluetooth-check.desktop \
20           file://op_bluetooth.desktop \          
21           file://op_startupmanager.sh \
22 #          file://op_startupmanager.desktop \
23           file://op_switchgui.sh \
24 #          file://op_switchgui.desktop \
25           file://startnetbooklauncher \
26           file://startmmenu \    
27           file://startpmenu \ 
28           file://op_calibrate.sh \
29 #          file://op_calibrate.desktop \
30           file://op_datetime.sh \
31 #          file://op_datetime.desktop \
32           file://op_usermanager.sh \
33 #          file://op_usermanager.desktop \
34           file://op_gammamanager.sh \
35 #          file://op_gammamanager.desktop \
36           file://op_nubmode.sh \
37 #         file://op_nubmode.desktop \
38           file://gui.conf \
39           file://gamma.conf \
40           file://op_env.sh \
41           file://pandorascripts.pnd \
42 "
43
44 do_install() {
45           install -d ${D}${prefix}/pandora/scripts/
46           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
47           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
48           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
49           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
50           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
51           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
52           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
53           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
54           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
55           install -m 0755 ${WORKDIR}/op_gammamanager.sh ${D}${prefix}/pandora/scripts/
56           install -m 0755 ${WORKDIR}/op_nubmode.sh ${D}${prefix}/pandora/scripts/
57
58           install -d ${D}${prefix}/pandora/apps/
59           install -m 0755 ${WORKDIR}/pandorascripts.pnd ${D}${prefix}/pandora/apps/
60
61           install -d ${D}${datadir}/applications/
62 #         install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
63 #          install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
64           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
65           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
66 #          install -m 0644 ${WORKDIR}/op_startupmanager.desktop ${D}${datadir}/applications/
67 #          install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
68 #          install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
69 #          install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
70 #         install -m 0644 ${WORKDIR}/op_usermanager.desktop ${D}${datadir}/applications/
71 #          install -m 0644 ${WORKDIR}/op_gammamanager.desktop ${D}${datadir}/applications/
72 #         install -m 0644 ${WORKDIR}/op_nubmode.desktop ${D}${datadir}/applications/
73           
74           install -d ${D}${sysconfdir}/xdg/autostart/
75           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
76
77           install -d ${D}${sysconfdir}/pandora/conf/
78           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
79           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
80         
81           install -d ${D}${sysconfdir}/profile.d/
82           install -m 0755 ${WORKDIR}/op_env.sh {D}${sysconfdir}/profile.d/
83
84           install -d ${D}${bindir}/
85           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
86           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
87           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
88 }
89
90 PACKAGE_ARCH = "${MACHINE_ARCH}"
91
92 FILES_${PN} += "${prefix} ${datadir}"