pandora-scripts: username handling fixes from russ
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 RDEPENDS = "bash sed gawk grep zenity"
7
8 PR = "r157"
9
10 SRC_URI = " \
11           file://op_paths.sh \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.pnd \     
15           file://op_dspspeed.sh \
16           file://op_usbhost.sh \
17           file://op_usbhost.pnd \
18           file://op_osupgrade.sh \
19           file://op_osupgrade.pnd \
20           file://op_sysspeed.sh \
21           file://op_createsd.sh \
22           file://op_createsd.pnd \
23           file://op_startupmanager.sh \
24           file://op_startupmanager.pnd \
25           file://op_switchgui.sh \
26           file://op_switchgui.pnd \
27           file://startmmenu \    
28           file://stopmmenu \
29           file://op_calibrate.sh \
30           file://op_calibrate.pnd \
31           file://op_datetime.sh \
32           file://op_datetime.pnd \
33           file://op_usermanager.sh \
34           file://op_usermanager.pnd \
35           file://op_lcdsettings.sh \
36           file://op_lcdsettings.pnd \
37           file://op_ledsettings.sh \
38           file://op_ledsettings.pnd \
39           file://op_cpusettings.sh \
40           file://op_cpusettings.pnd \
41 #          file://compo4all-manager.pnd \
42           file://op_lcdrate.sh \
43           file://op_videofir.sh \
44           file://op_storage.sh \
45           file://op_storage.pnd \
46           file://op_nubmode.py \
47           file://op_nubmode.pnd \
48           file://op_nubchange.sh \
49           file://op_lidsettings.pnd \
50           file://op_lidsettings.sh \
51           file://op_touchinit.sh \
52           file://op_tvout.sh \
53           file://op_tvout.pnd \
54           file://op_tvout_layer.sh \
55           file://ConfigModel.py \
56           file://TVoutConfig.py \
57           file://op_inputtest.pnd \
58           file://gui.conf \
59           file://cpu.conf \
60           file://dsp.conf \
61           file://led.conf \
62           file://gamma.conf \
63           file://service.conf \
64           file://nub_profiles.conf \
65           file://tvout-profiles.conf \
66           file://nubmode.glade \
67           file://reset_nubs.sh \
68           file://pndlogo.png \
69           file://tvicon.png \
70           file://tvout.glade \
71           file://default_up \
72           file://none_up \
73           file://op_env.sh \
74           file://evince.pnd \
75           file://gigolo.pnd \
76           file://mousepad.pnd \
77           file://ristretto.pnd \
78           file://squeeze.pnd \
79           file://thunar.pnd \
80           file://xchat.pnd \
81           file://gcalctool.pnd \ 
82           file://op_bright_down.sh \ 
83           file://op_lid.sh \  
84           file://op_power.sh \
85           file://op_battlow.sh \ 
86           file://op_bright_up.sh \  
87           file://op_menu.sh \ 
88           file://op_xfcemenu.sh \
89           file://op_hugetlb.sh \
90           file://op_gamma.sh \
91           file://op_getpndmg.sh \
92           file://op_dsp.sh \
93 "
94
95 do_install() {
96           install -d ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_getpndmg.sh ${D}${prefix}/pandora/scripts/
99           install -m 0755 ${WORKDIR}/op_osupgrade.sh ${D}${prefix}/pandora/scripts/
100           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
101           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
102           install -m 0755 ${WORKDIR}/op_dspspeed.sh ${D}${prefix}/pandora/scripts/
103           install -m 0755 ${WORKDIR}/op_createsd.sh ${D}${prefix}/pandora/scripts/
104           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
105           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
106           install -m 0755 ${WORKDIR}/op_usbhost.sh ${D}${prefix}/pandora/scripts/
107           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
108           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
109           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
110           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
111           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
112           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
113           install -m 0755 ${WORKDIR}/op_ledsettings.sh ${D}${prefix}/pandora/scripts/
114           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
115           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
116           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
117           install -m 0755 ${WORKDIR}/op_nubchange.sh ${D}${prefix}/pandora/scripts/
118           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
119           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
120           install -m 0755 ${WORKDIR}/op_tvout_layer.sh ${D}${prefix}/pandora/scripts/
121           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
122           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
123           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
124           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
125           install -m 0755 ${WORKDIR}/op_touchinit.sh ${D}${prefix}/pandora/scripts/ 
126           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
127           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
128           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
129           install -m 0755 ${WORKDIR}/op_hugetlb.sh ${D}${prefix}/pandora/scripts/
130           install -m 0755 ${WORKDIR}/op_gamma.sh ${D}${prefix}/pandora/scripts/
131           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
132           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
133           install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
134           install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
135           install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
136           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
137           install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
138           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
139           install -m 0755 ${WORKDIR}/op_dsp.sh ${D}${prefix}/pandora/scripts/ 
140
141
142           install -d ${D}${prefix}/pandora/apps/
143           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
144           install -m 0755 ${WORKDIR}/op_createsd.pnd ${D}${prefix}/pandora/apps/
145           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
146           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
147           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
148           install -m 0755 ${WORKDIR}/op_ledsettings.pnd ${D}${prefix}/pandora/apps/
149           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
150           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
151           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
152           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
153           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
154           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
155           install -m 0755 ${WORKDIR}/op_usbhost.pnd ${D}${prefix}/pandora/apps/
156           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
157           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
158           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
159           install -m 0755 ${WORKDIR}/op_osupgrade.pnd ${D}${prefix}/pandora/apps/
160 #         install -m 0755 ${WORKDIR}/compo4all-manager.pnd ${D}${prefix}/pandora/apps/
161
162           install -d ${D}${prefix}/pandora/mmenu/
163           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
164           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
165           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
166           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
167           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
168           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
169           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
170           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
171
172           install -d ${D}${sysconfdir}/pandora/conf/
173           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
174           install -m 0644 ${WORKDIR}/led.conf ${D}${sysconfdir}/pandora/conf/led.conf
175           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
176           install -m 0644 ${WORKDIR}/dsp.conf ${D}${sysconfdir}/pandora/conf/dsp.conf
177           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
178           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
179           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
180           install -m 0666 ${WORKDIR}/tvout-profiles.conf ${D}${sysconfdir}/pandora/conf/tvout-profiles.conf
181
182           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
183           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
184           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
185
186           install -d ${D}${sysconfdir}/profile.d/
187           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
188
189           install -d ${D}${bindir}/
190           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
191           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
192 }
193
194 PACKAGE_ARCH = "${MACHINE_ARCH}"
195
196 FILES_${PN} += "${prefix} ${datadir}"
197
198 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gui.conf
199 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/cpu.conf
200 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/dsp.conf
201 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/led.conf
202 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/gamma.conf
203 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/service.conf
204 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/nub_profiles.conf
205 CONFFILES_${PN} += ${sysconfdir}/pandora/conf/tvout-profiles.conf