pandora-scripts: Add latest startmenu script.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r10"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.desktop \          
16           file://op_wifi.sh \
17           file://op_wifi.desktop \          
18           file://op_bluetooth.sh \
19           file://op_bluetooth-check.desktop \
20           file://op_bluetooth.desktop \          
21           file://op_defaultgui.sh \
22           file://op_defaultgui.desktop \
23           file://op_switchgui.sh \
24           file://op_switchgui.desktop \
25           file://startnetbooklauncher \
26           file://startmmenu \          
27 "
28
29 do_install() {
30           install -d ${D}${prefix}/pandora/scripts/
31           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
32           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
33           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
34           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
35           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
36           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
37           
38           install -d ${D}${datadir}/applications/
39           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
40           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
41           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
42           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
43           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
44           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
45
46           install -d ${D}${sysconfdir}/xdg/autostart/
47           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
48
49           install -d ${D}${bindir}/
50           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
51           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/          
52 }
53
54 PACKAGE_ARCH = "${MACHINE_ARCH}"
55
56 FILES_${PN} += "${prefix} ${datadir}"