desktop-files: Changed a few categories for the scripts
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r12"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.desktop \          
15           file://op_wifi.sh \
16           file://op_wifi.desktop \          
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_defaultgui.sh \
21           file://op_defaultgui.desktop \
22           file://op_switchgui.sh \
23           file://op_switchgui.desktop \
24           file://startnetbooklauncher \
25           file://startmmenu \          
26           file://op_calibrate.sh \
27           file://op_calibrate.desktop \
28           file://op_datetime.sh \
29           file://op_datetime.desktop \
30           file://op_usermanager.sh \
31           file://op_usermanager.desktop \
32           file://gui.conf \
33 "
34
35 do_install() {
36           install -d ${D}${prefix}/pandora/scripts/
37           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
38           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
39           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
40           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
41           install -m 0755 ${WORKDIR}/op_defaultgui.sh ${D}${prefix}/pandora/scripts/
42           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
43           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
44           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
45           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
46           
47           install -d ${D}${datadir}/applications/
48           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
49           install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
50           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
51           install -m 0644 ${WORKDIR}/op_defaultgui.desktop ${D}${datadir}/applications/
52           install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
53           install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
54           install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
55           install -m 0644 ${WORKDIR}/op_usermanager.desktop ${D}${datadir}/applications/
56           
57           install -d ${D}${sysconfdir}/xdg/autostart/
58           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
59
60           install -d ${D}${sysconfdir}/pandora/conf/
61           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
62
63           install -d ${D}${bindir}/
64           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
65           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
66 }
67
68 PACKAGE_ARCH = "${MACHINE_ARCH}"
69
70 FILES_${PN} += "${prefix} ${datadir}"