b120e0bc4df7e7d8f60d723824ee3cb1e32bffb5
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r87"
10
11 SRC_URI = " \
12           file://op_paths.sh \
13           file://op_bright.sh \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.pnd \          
16           file://op_wifi.sh \
17           file://op_wifi.pnd \  
18           file://op_bluetooth.sh \
19           file://op_bluetooth-check.desktop \
20           file://op_bluetooth.desktop \          
21           file://op_startupmanager.sh \
22           file://op_startupmanager.pnd \
23           file://op_switchgui.sh \
24           file://op_switchgui.pnd \
25           file://startnetbooklauncher \
26           file://startmmenu \    
27           file://startpmenu \ 
28           file://stopmmenu \
29           file://op_calibrate.sh \
30           file://op_calibrate.pnd \
31           file://op_datetime.sh \
32           file://op_datetime.pnd \
33           file://op_usermanager.sh \
34           file://op_usermanager.pnd \
35           file://op_lcdsettings.sh \
36           file://op_lcdsettings.pnd \
37           file://op_cpusettings.sh \
38           file://op_cpusettings.pnd \
39           file://op_lcdrate.sh \
40           file://op_videofir.sh \
41           file://op_storage.sh \
42           file://op_storage.pnd \
43           file://op_nubmode.py \
44           file://op_nubmode.pnd \
45           file://op_lidsettings.pnd \
46           file://op_lidsettings.sh \
47           file://op_tvout.sh \
48           file://op_tvout.pnd \
49           file://ConfigModel.py \
50           file://TVoutConfig.py \
51           file://op_inputtest.pnd \
52           file://gui.conf \
53           file://cpu.conf \
54           file://gamma.conf \
55           file://service.conf \
56           file://nub_profiles.conf \
57           file://tvout-profiles.conf \
58           file://nubmode.glade \
59           file://reset_nubs.sh \
60           file://pndlogo.png \
61           file://tvicon.png \
62           file://tvout.glade \
63           file://default_up \
64           file://none_up \
65           file://op_env.sh \
66           file://evince.pnd \
67           file://gigolo.pnd \
68           file://mousepad.pnd \
69           file://ristretto.pnd \
70           file://squeeze.pnd \
71           file://thunar.pnd \
72           file://xchat.pnd \
73           file://gcalctool.pnd \ 
74           file://op_bright_down.sh \ 
75           file://op_lid.sh \  
76           file://op_power.sh \
77           file://op_battlow.sh \ 
78           file://op_bright_up.sh \  
79           file://op_menu.sh \ 
80           file://op_xfcemenu.sh \
81 "
82
83 do_install() {
84           install -d ${D}${prefix}/pandora/scripts/
85           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
86           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
87           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
88           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
89           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
90           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
91           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
96           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
99           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
100           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
101           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
102           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
103           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
104           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
105           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
106           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
107           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
108           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
109           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
110           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
111           install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
112           install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
113           install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
114           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
115           install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
116           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
117
118
119
120           install -d ${D}${prefix}/pandora/apps/
121           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
122           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
123           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
124           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
125           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
126           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
127           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
128           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
129           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
130           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
131           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
132           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
133           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
134           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
135
136           install -d ${D}${prefix}/pandora/mmenu/
137           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
138           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
139           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
140           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
141           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
142           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
143           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
144           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
145
146           install -d ${D}${datadir}/applications/
147           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
148           
149           install -d ${D}${sysconfdir}/xdg/autostart/
150           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
151
152           install -d ${D}${sysconfdir}/pandora/conf/
153           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
154           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
155           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
156           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
157           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
158           install -m 0666 ${WORKDIR}/tvout-profiles.conf ${D}${sysconfdir}/pandora/conf/tvout-profiles.conf
159
160           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
161           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
162           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
163
164           install -d ${D}${sysconfdir}/profile.d/
165           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
166
167           install -d ${D}${bindir}/
168           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
169           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
170           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
171           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
172 }
173
174 PACKAGE_ARCH = "${MACHINE_ARCH}"
175
176 FILES_${PN} += "${prefix} ${datadir}"