a80a15d75f9d38355e2b8e1c81b1af272c9e8f26
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r64"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.pnd \          
15           file://op_wifi.sh \
16           file://op_wifi.pnd \  
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_startupmanager.sh \
21           file://op_startupmanager.pnd \
22           file://op_switchgui.sh \
23           file://op_switchgui.pnd \
24           file://startnetbooklauncher \
25           file://startmmenu \    
26           file://startpmenu \ 
27           file://stopmmenu \
28           file://op_calibrate.sh \
29           file://op_calibrate.pnd \
30           file://op_datetime.sh \
31           file://op_datetime.pnd \
32           file://op_usermanager.sh \
33           file://op_usermanager.pnd \
34           file://op_lcdsettings.sh \
35           file://op_lcdsettings.pnd \
36           file://op_cpusettings.sh \
37           file://op_cpusettings.pnd \
38           file://op_lcdrate.sh \
39           file://op_videofir.sh \
40           file://op_storage.sh \
41           file://op_storage.pnd \
42           file://op_nubmode.py \
43           file://op_nubmode.pnd \
44           file://op_tvout.sh \
45           file://op_tvout.pnd \
46           file://op_inputtest.pnd \
47           file://gui.conf \
48           file://cpu.conf \
49           file://gamma.conf \
50           file://service.conf \
51           file://nub_profiles.conf \
52           file://nubmode.glade \
53           file://reset_nubs.sh \
54           file://pndlogo.png \
55           file://default_up \
56           file://none_up \
57           file://op_env.sh \
58           file://evince.pnd \
59           file://gigolo.pnd \
60           file://mousepad.pnd \
61           file://ristretto.pnd \
62           file://squeeze.pnd \
63           file://thunar.pnd \
64           file://xchat.pnd \
65           file://gcalctool.pnd \ 
66           file://op_bright_down.sh \ 
67           file://op_lid.sh \  
68           file://op_power.sh \
69           file://op_battlow.sh \ 
70           file://op_bright_up.sh \  
71           file://op_menu.sh \ 
72 "
73
74 do_install() {
75           install -d ${D}${prefix}/pandora/scripts/
76           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
77           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
78           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
79           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
80           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
81           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
82           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
83           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
84           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
85           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
86           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
87           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
88           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
89           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
90           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
91           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
96           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
97           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
98           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
99           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
100           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
101
102
103
104           install -d ${D}${prefix}/pandora/apps/
105           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
106           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
107           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
108           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
109           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
110           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
111           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
112           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
113           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
114           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
115           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
116           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
117           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
118
119           install -d ${D}${prefix}/pandora/mmenu/
120           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
121           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
122           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
123           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
124           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
125           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
126           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
127           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
128
129           install -d ${D}${datadir}/applications/
130           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
131           
132           install -d ${D}${sysconfdir}/xdg/autostart/
133           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
134
135           install -d ${D}${sysconfdir}/pandora/conf/
136           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
137           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
138           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
139           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
140           install -m 0644 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
141
142           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
143           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
144           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
145
146           install -d ${D}${sysconfdir}/profile.d/
147           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
148
149           install -d ${D}${bindir}/
150           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
151           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
152           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
153           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
154 }
155
156 PACKAGE_ARCH = "${MACHINE_ARCH}"
157
158 FILES_${PN} += "${prefix} ${datadir}"