9d4c2346d4297809ceb5d39e0546fa0b4e9123f4
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r90"
10
11 SRC_URI = " \
12           file://op_paths.sh \
13           file://op_bright.sh \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.pnd \          
16           file://op_sysspeed.sh \
17           file://op_wifi.sh \
18           file://op_wifi.pnd \  
19           file://op_bluetooth.sh \
20           file://op_bluetooth-check.desktop \
21           file://op_bluetooth.desktop \          
22           file://op_startupmanager.sh \
23           file://op_startupmanager.pnd \
24           file://op_switchgui.sh \
25           file://op_switchgui.pnd \
26           file://startnetbooklauncher \
27           file://startmmenu \    
28           file://startpmenu \ 
29           file://stopmmenu \
30           file://op_calibrate.sh \
31           file://op_calibrate.pnd \
32           file://op_datetime.sh \
33           file://op_datetime.pnd \
34           file://op_usermanager.sh \
35           file://op_usermanager.pnd \
36           file://op_lcdsettings.sh \
37           file://op_lcdsettings.pnd \
38           file://op_cpusettings.sh \
39           file://op_cpusettings.pnd \
40           file://op_lcdrate.sh \
41           file://op_videofir.sh \
42           file://op_storage.sh \
43           file://op_storage.pnd \
44           file://op_nubmode.py \
45           file://op_nubmode.pnd \
46           file://op_lidsettings.pnd \
47           file://op_lidsettings.sh \
48           file://op_tvout.sh \
49           file://op_tvout.pnd \
50           file://ConfigModel.py \
51           file://TVoutConfig.py \
52           file://op_inputtest.pnd \
53           file://gui.conf \
54           file://cpu.conf \
55           file://gamma.conf \
56           file://service.conf \
57           file://nub_profiles.conf \
58           file://tvout-profiles.conf \
59           file://nubmode.glade \
60           file://reset_nubs.sh \
61           file://pndlogo.png \
62           file://tvicon.png \
63           file://tvout.glade \
64           file://default_up \
65           file://none_up \
66           file://op_env.sh \
67           file://evince.pnd \
68           file://gigolo.pnd \
69           file://mousepad.pnd \
70           file://ristretto.pnd \
71           file://squeeze.pnd \
72           file://thunar.pnd \
73           file://xchat.pnd \
74           file://gcalctool.pnd \ 
75           file://op_bright_down.sh \ 
76           file://op_lid.sh \  
77           file://op_power.sh \
78           file://op_battlow.sh \ 
79           file://op_bright_up.sh \  
80           file://op_menu.sh \ 
81           file://op_xfcemenu.sh \
82 "
83
84 do_install() {
85           install -d ${D}${prefix}/pandora/scripts/
86           install -m 0755 ${WORKDIR}/op_paths.sh ${D}${prefix}/pandora/scripts/
87           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
88           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
89           install -m 0755 ${WORKDIR}/op_sysspeed.sh ${D}${prefix}/pandora/scripts/
90           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
91           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
96           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
99           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
100           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
101           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
102           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
103           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
104           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
105           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
106           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
107           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
108           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
109           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
110           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
111           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
112           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
113           install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
114           install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
115           install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
116           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
117           install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
118           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
119
120
121
122           install -d ${D}${prefix}/pandora/apps/
123           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
124           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
125           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
126           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
127           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
128           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
129           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
130           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
131           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
132           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
133           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
134           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
135           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
136           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
137
138           install -d ${D}${prefix}/pandora/mmenu/
139           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
140           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
141           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
142           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
143           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
144           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
145           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
146           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
147
148           install -d ${D}${datadir}/applications/
149           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
150           
151           install -d ${D}${sysconfdir}/xdg/autostart/
152           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
153
154           install -d ${D}${sysconfdir}/pandora/conf/
155           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
156           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
157           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
158           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
159           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
160           install -m 0666 ${WORKDIR}/tvout-profiles.conf ${D}${sysconfdir}/pandora/conf/tvout-profiles.conf
161
162           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
163           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
164           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
165
166           install -d ${D}${sysconfdir}/profile.d/
167           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
168
169           install -d ${D}${bindir}/
170           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
171           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
172           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
173           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
174 }
175
176 PACKAGE_ARCH = "${MACHINE_ARCH}"
177
178 FILES_${PN} += "${prefix} ${datadir}"