Pandora-Scripts: Added check for g_cdc in op_storage.sh
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r28"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13 #          file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15 #          file://op_cpuspeed.desktop \          
16           file://op_wifi.sh \
17 #          file://op_wifi.desktop \          
18           file://op_bluetooth.sh \
19           file://op_bluetooth-check.desktop \
20           file://op_bluetooth.desktop \          
21           file://op_startupmanager.sh \
22 #          file://op_startupmanager.desktop \
23           file://op_switchgui.sh \
24 #          file://op_switchgui.desktop \
25           file://startnetbooklauncher \
26           file://startmmenu \    
27           file://startpmenu \ 
28           file://stopmmenu \
29           file://op_calibrate.sh \
30 #          file://op_calibrate.desktop \
31           file://op_datetime.sh \
32 #          file://op_datetime.desktop \
33           file://op_usermanager.sh \
34 #          file://op_usermanager.desktop \
35           file://op_lcdsettings.sh \
36 #          file://op_lcdsettings.desktop \
37            file://op_lcdrate.sh \
38           file://op_storage.sh \
39           file://op_nubmode.sh \
40 #         file://op_nubmode.desktop \
41           file://gui.conf \
42           file://gamma.conf \
43           file://service.conf \
44           file://op_env.sh \
45           file://pandorascripts.pnd \
46           file://abiword.pnd \
47           file://arora.pnd \
48           file://claws-mail.pnd \
49           file://evince.pnd \
50           file://gigolo.pnd \
51           file://gnumeric.pnd \
52           file://midori.pnd \
53           file://mousepad.pnd \
54           file://pidgin.pnd \
55           file://ristretto.pnd \
56           file://squeeze.pnd \
57           file://thunar.pnd \
58           file://xchat.pnd \
59 "
60
61 do_install() {
62           install -d ${D}${prefix}/pandora/scripts/
63           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
64           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
65           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
66           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
67           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
68           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
69           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
70           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
71           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
72           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
73           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
74           install -m 0755 ${WORKDIR}/op_nubmode.sh ${D}${prefix}/pandora/scripts/
75           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
76
77           install -d ${D}${prefix}/pandora/menu/
78           install -m 0755 ${WORKDIR}/pandorascripts.pnd ${D}${prefix}/pandora/menu/
79           install -d ${D}${prefix}/pandora/mmenu/
80           install -m 0755 ${WORKDIR}/abiword.pnd ${D}${prefix}/pandora/mmenu/
81           install -m 0755 ${WORKDIR}/arora.pnd ${D}${prefix}/pandora/mmenu/
82           install -m 0755 ${WORKDIR}/claws-mail.pnd ${D}${prefix}/pandora/mmenu/
83           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
84           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
85           install -m 0755 ${WORKDIR}/gnumeric.pnd ${D}${prefix}/pandora/mmenu/
86           install -m 0755 ${WORKDIR}/midori.pnd ${D}${prefix}/pandora/mmenu/
87           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
88           install -m 0755 ${WORKDIR}/pidgin.pnd ${D}${prefix}/pandora/mmenu/
89           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
90           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
91           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
92           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
93
94           install -d ${D}${datadir}/applications/
95 #         install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
96 #          install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/
97 #          install -m 0644 ${WORKDIR}/op_wifi.desktop ${D}${datadir}/applications/
98           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
99 #          install -m 0644 ${WORKDIR}/op_startupmanager.desktop ${D}${datadir}/applications/
100 #          install -m 0644 ${WORKDIR}/op_switchgui.desktop ${D}${datadir}/applications/          
101 #          install -m 0644 ${WORKDIR}/op_calibrate.desktop ${D}${datadir}/applications/
102 #          install -m 0644 ${WORKDIR}/op_datetime.desktop ${D}${datadir}/applications/
103 #          install -m 0644 ${WORKDIR}/op_usermanager.desktop ${D}${datadir}/applications/
104 #          install -m 0644 ${WORKDIR}/op_lcdsettings.desktop ${D}${datadir}/applications/
105 #         install -m 0644 ${WORKDIR}/op_nubmode.desktop ${D}${datadir}/applications/
106           
107           install -d ${D}${sysconfdir}/xdg/autostart/
108           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
109
110           install -d ${D}${sysconfdir}/pandora/conf/
111           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
112           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
113           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
114
115           install -d ${D}${sysconfdir}/profile.d/
116           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
117
118           install -d ${D}${bindir}/
119           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
120           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
121           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
122           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
123 }
124
125 PACKAGE_ARCH = "${MACHINE_ARCH}"
126
127 FILES_${PN} += "${prefix} ${datadir}"