51b8ae79080a0441ff63c32b4bc8947a259cfed3
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 PR = "r3"
7
8 SRC_URI = " \
9           file://op_bright.sh \
10           file://op_bright.desktop \
11           file://op_cpuspeed.sh \
12           file://op_cpuspeed.desktop \          
13 "
14
15 do_install() {
16           install -d ${D}${prefix}/pandora/scripts/
17           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
18           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/          
19           install -d ${D}${datadir}/applications/
20           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
21           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/          
22 }
23
24 PACKAGE_ARCH = "${MACHINE_ARCH}"
25
26 FILES_${PN} += "${prefix} ${datadir}"