11cc330d8f952494b1d32571c00780022145a2ba
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r75"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.pnd \          
15           file://op_wifi.sh \
16           file://op_wifi.pnd \  
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_startupmanager.sh \
21           file://op_startupmanager.pnd \
22           file://op_switchgui.sh \
23           file://op_switchgui.pnd \
24           file://startnetbooklauncher \
25           file://startmmenu \    
26           file://startpmenu \ 
27           file://stopmmenu \
28           file://op_calibrate.sh \
29           file://op_calibrate.pnd \
30           file://op_datetime.sh \
31           file://op_datetime.pnd \
32           file://op_usermanager.sh \
33           file://op_usermanager.pnd \
34           file://op_lcdsettings.sh \
35           file://op_lcdsettings.pnd \
36           file://op_cpusettings.sh \
37           file://op_cpusettings.pnd \
38           file://op_lcdrate.sh \
39           file://op_videofir.sh \
40           file://op_storage.sh \
41           file://op_storage.pnd \
42           file://op_nubmode.py \
43           file://op_nubmode.pnd \
44           file://op_lidsettings.pnd \
45           file://op_lidsettings.sh \
46           file://op_tvout.sh \
47           file://op_tvout.pnd \
48           file://ConfigModel.py \
49           file://TVoutConfig.py \
50           file://op_inputtest.pnd \
51           file://gui.conf \
52           file://cpu.conf \
53           file://gamma.conf \
54           file://service.conf \
55           file://nub_profiles.conf \
56           file://tvout-profiles.conf \
57           file://nubmode.glade \
58           file://reset_nubs.sh \
59           file://pndlogo.png \
60           file://tvicon.png \
61           file://tvout.glade \
62           file://default_up \
63           file://none_up \
64           file://op_env.sh \
65           file://evince.pnd \
66           file://gigolo.pnd \
67           file://mousepad.pnd \
68           file://ristretto.pnd \
69           file://squeeze.pnd \
70           file://thunar.pnd \
71           file://xchat.pnd \
72           file://gcalctool.pnd \ 
73           file://op_bright_down.sh \ 
74           file://op_lid.sh \  
75           file://op_power.sh \
76           file://op_battlow.sh \ 
77           file://op_bright_up.sh \  
78           file://op_menu.sh \ 
79           file://op_xfcemenu.sh \
80 "
81
82 do_install() {
83           install -d ${D}${prefix}/pandora/scripts/
84           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
85           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
86           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
87           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
88           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
89           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
90           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
91           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
96           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
99           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
100           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
101           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
102           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
103           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
104           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
105           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
106           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
107           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
108           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
109           install -m 0755 ${WORKDIR}/ConfigModel.py ${D}${prefix}/pandora/scripts/
110           install -m 0755 ${WORKDIR}/TVoutConfig.py ${D}${prefix}/pandora/scripts/
111           install -m 0644 ${WORKDIR}/tvicon.png ${D}${prefix}/pandora/scripts/ 
112           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
113           install -m 0644 ${WORKDIR}/tvout.glade ${D}${prefix}/pandora/scripts/ 
114           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
115
116
117
118           install -d ${D}${prefix}/pandora/apps/
119           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
120           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
121           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
122           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
123           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
124           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
125           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
126           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
127           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
128           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
129           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
130           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
131           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
132           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
133
134           install -d ${D}${prefix}/pandora/mmenu/
135           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
136           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
137           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
138           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
139           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
140           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
141           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
142           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
143
144           install -d ${D}${datadir}/applications/
145           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
146           
147           install -d ${D}${sysconfdir}/xdg/autostart/
148           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
149
150           install -d ${D}${sysconfdir}/pandora/conf/
151           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
152           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
153           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
154           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
155           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
156
157           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
158           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
159           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
160
161           install -d ${D}${sysconfdir}/profile.d/
162           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
163
164           install -d ${D}${bindir}/
165           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
166           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
167           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
168           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
169 }
170
171 PACKAGE_ARCH = "${MACHINE_ARCH}"
172
173 FILES_${PN} += "${prefix} ${datadir}"