various: reset PR of tasks following mainline Angstrom DISTRO_PR bump. Cosmetic change.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r1"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_bright.desktop \
14           file://op_cpuspeed.sh \
15           file://op_cpuspeed.desktop \          
16 "
17
18 do_install() {
19           install -d ${D}${prefix}/pandora/scripts/
20           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
21           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/          
22           install -d ${D}${datadir}/applications/
23           install -m 0644 ${WORKDIR}/op_bright.desktop ${D}${datadir}/applications/
24           install -m 0644 ${WORKDIR}/op_cpuspeed.desktop ${D}${datadir}/applications/          
25 }
26
27 PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29 FILES_${PN} += "${prefix} ${datadir}"