10dc789d30bd89d02fc7460c07b91b572e3f529a
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 DEPENDS = "zenity dbus"
7 RDEPENDS = "zenity dbus"
8
9 PR = "r72"
10
11 SRC_URI = " \
12           file://op_bright.sh \
13           file://op_cpuspeed.sh \
14           file://op_cpuspeed.pnd \          
15           file://op_wifi.sh \
16           file://op_wifi.pnd \  
17           file://op_bluetooth.sh \
18           file://op_bluetooth-check.desktop \
19           file://op_bluetooth.desktop \          
20           file://op_startupmanager.sh \
21           file://op_startupmanager.pnd \
22           file://op_switchgui.sh \
23           file://op_switchgui.pnd \
24           file://startnetbooklauncher \
25           file://startmmenu \    
26           file://startpmenu \ 
27           file://stopmmenu \
28           file://op_calibrate.sh \
29           file://op_calibrate.pnd \
30           file://op_datetime.sh \
31           file://op_datetime.pnd \
32           file://op_usermanager.sh \
33           file://op_usermanager.pnd \
34           file://op_lcdsettings.sh \
35           file://op_lcdsettings.pnd \
36           file://op_cpusettings.sh \
37           file://op_cpusettings.pnd \
38           file://op_lcdrate.sh \
39           file://op_videofir.sh \
40           file://op_storage.sh \
41           file://op_storage.pnd \
42           file://op_nubmode.py \
43           file://op_nubmode.pnd \
44           file://op_lidsettings.pnd \
45           file://op_lidsettings.sh \
46           file://op_tvout.sh \
47           file://op_tvout.pnd \
48           file://op_inputtest.pnd \
49           file://gui.conf \
50           file://cpu.conf \
51           file://gamma.conf \
52           file://service.conf \
53           file://nub_profiles.conf \
54           file://nubmode.glade \
55           file://reset_nubs.sh \
56           file://pndlogo.png \
57           file://default_up \
58           file://none_up \
59           file://op_env.sh \
60           file://evince.pnd \
61           file://gigolo.pnd \
62           file://mousepad.pnd \
63           file://ristretto.pnd \
64           file://squeeze.pnd \
65           file://thunar.pnd \
66           file://xchat.pnd \
67           file://gcalctool.pnd \ 
68           file://op_bright_down.sh \ 
69           file://op_lid.sh \  
70           file://op_power.sh \
71           file://op_battlow.sh \ 
72           file://op_bright_up.sh \  
73           file://op_menu.sh \ 
74           file://op_xfcemenu.sh \
75 "
76
77 do_install() {
78           install -d ${D}${prefix}/pandora/scripts/
79           install -m 0755 ${WORKDIR}/op_bright.sh ${D}${prefix}/pandora/scripts/
80           install -m 0755 ${WORKDIR}/op_cpuspeed.sh ${D}${prefix}/pandora/scripts/
81           install -m 0755 ${WORKDIR}/op_cpusettings.sh ${D}${prefix}/pandora/scripts/
82           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
83           install -m 0755 ${WORKDIR}/op_bluetooth.sh ${D}${prefix}/pandora/scripts/
84           install -m 0755 ${WORKDIR}/op_startupmanager.sh ${D}${prefix}/pandora/scripts/
85           install -m 0755 ${WORKDIR}/op_switchgui.sh ${D}${prefix}/pandora/scripts/
86           install -m 0755 ${WORKDIR}/op_calibrate.sh ${D}${prefix}/pandora/scripts/
87           install -m 0755 ${WORKDIR}/op_datetime.sh ${D}${prefix}/pandora/scripts/
88           install -m 0755 ${WORKDIR}/op_usermanager.sh ${D}${prefix}/pandora/scripts/
89           install -m 0755 ${WORKDIR}/op_lcdsettings.sh ${D}${prefix}/pandora/scripts/
90           install -m 0755 ${WORKDIR}/op_lcdrate.sh ${D}${prefix}/pandora/scripts/
91           install -m 0755 ${WORKDIR}/op_videofir.sh ${D}${prefix}/pandora/scripts/
92           install -m 0755 ${WORKDIR}/op_nubmode.py ${D}${prefix}/pandora/scripts/
93           install -m 0755 ${WORKDIR}/op_storage.sh ${D}${prefix}/pandora/scripts/
94           install -m 0755 ${WORKDIR}/op_tvout.sh ${D}${prefix}/pandora/scripts/
95           install -m 0755 ${WORKDIR}/op_bright_down.sh ${D}${prefix}/pandora/scripts/
96           install -m 0755 ${WORKDIR}/op_lid.sh ${D}${prefix}/pandora/scripts/
97           install -m 0755 ${WORKDIR}/op_power.sh ${D}${prefix}/pandora/scripts/
98           install -m 0755 ${WORKDIR}/op_battlow.sh ${D}${prefix}/pandora/scripts/ 
99           install -m 0755 ${WORKDIR}/op_bright_up.sh ${D}${prefix}/pandora/scripts/  
100           install -m 0755 ${WORKDIR}/op_menu.sh ${D}${prefix}/pandora/scripts/ 
101           install -m 0755 ${WORKDIR}/op_xfcemenu.sh ${D}${prefix}/pandora/scripts/ 
102           install -m 0755 ${WORKDIR}/reset_nubs.sh ${D}${prefix}/pandora/scripts/ 
103           install -m 0644 ${WORKDIR}/pndlogo.png ${D}${prefix}/pandora/scripts/ 
104           install -m 0644 ${WORKDIR}/nubmode.glade ${D}${prefix}/pandora/scripts/ 
105           install -m 0755 ${WORKDIR}/op_lidsettings.sh ${D}${prefix}/pandora/scripts/ 
106
107
108
109           install -d ${D}${prefix}/pandora/apps/
110           install -m 0755 ${WORKDIR}/op_calibrate.pnd ${D}${prefix}/pandora/apps/
111           install -m 0755 ${WORKDIR}/op_cpuspeed.pnd ${D}${prefix}/pandora/apps/
112           install -m 0755 ${WORKDIR}/op_datetime.pnd ${D}${prefix}/pandora/apps/
113           install -m 0755 ${WORKDIR}/op_lcdsettings.pnd ${D}${prefix}/pandora/apps/
114           install -m 0755 ${WORKDIR}/op_cpusettings.pnd ${D}${prefix}/pandora/apps/
115           install -m 0755 ${WORKDIR}/op_nubmode.pnd ${D}${prefix}/pandora/apps/
116           install -m 0755 ${WORKDIR}/op_startupmanager.pnd ${D}${prefix}/pandora/apps/
117           install -m 0755 ${WORKDIR}/op_storage.pnd ${D}${prefix}/pandora/apps/
118           install -m 0755 ${WORKDIR}/op_switchgui.pnd ${D}${prefix}/pandora/apps/
119           install -m 0755 ${WORKDIR}/op_usermanager.pnd ${D}${prefix}/pandora/apps/
120           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
121           install -m 0755 ${WORKDIR}/op_tvout.pnd ${D}${prefix}/pandora/apps/
122           install -m 0755 ${WORKDIR}/op_inputtest.pnd ${D}${prefix}/pandora/apps/
123           install -m 0755 ${WORKDIR}/op_lidsettings.pnd ${D}${prefix}/pandora/apps/
124
125           install -d ${D}${prefix}/pandora/mmenu/
126           install -m 0755 ${WORKDIR}/evince.pnd ${D}${prefix}/pandora/mmenu/
127           install -m 0755 ${WORKDIR}/gigolo.pnd ${D}${prefix}/pandora/mmenu/
128           install -m 0755 ${WORKDIR}/mousepad.pnd ${D}${prefix}/pandora/mmenu/
129           install -m 0755 ${WORKDIR}/ristretto.pnd ${D}${prefix}/pandora/mmenu/
130           install -m 0755 ${WORKDIR}/squeeze.pnd ${D}${prefix}/pandora/mmenu/
131           install -m 0755 ${WORKDIR}/thunar.pnd ${D}${prefix}/pandora/mmenu/
132           install -m 0755 ${WORKDIR}/xchat.pnd ${D}${prefix}/pandora/mmenu/
133           install -m 0755 ${WORKDIR}/gcalctool.pnd ${D}${prefix}/pandora/mmenu/
134
135           install -d ${D}${datadir}/applications/
136           install -m 0644 ${WORKDIR}/op_bluetooth.desktop ${D}${datadir}/applications/
137           
138           install -d ${D}${sysconfdir}/xdg/autostart/
139           install -m 0644 ${WORKDIR}/op_bluetooth-check.desktop ${D}${sysconfdir}/xdg/autostart/op_bluetooth-check.desktop
140
141           install -d ${D}${sysconfdir}/pandora/conf/
142           install -m 0644 ${WORKDIR}/gui.conf ${D}${sysconfdir}/pandora/conf/gui.conf
143           install -m 0644 ${WORKDIR}/cpu.conf ${D}${sysconfdir}/pandora/conf/cpu.conf
144           install -m 0644 ${WORKDIR}/gamma.conf ${D}${sysconfdir}/pandora/conf/gamma.conf
145           install -m 0644 ${WORKDIR}/service.conf ${D}${sysconfdir}/pandora/conf/service.conf
146           install -m 0666 ${WORKDIR}/nub_profiles.conf ${D}${sysconfdir}/pandora/conf/nub_profiles.conf
147
148           install -d ${D}${sysconfdir}/pandora/conf/dss_fir/
149           install -m 0644 ${WORKDIR}/default_up ${D}${sysconfdir}/pandora/conf/dss_fir/
150           install -m 0644 ${WORKDIR}/none_up ${D}${sysconfdir}/pandora/conf/dss_fir/
151
152           install -d ${D}${sysconfdir}/profile.d/
153           install -m 0755 ${WORKDIR}/op_env.sh ${D}${sysconfdir}/profile.d/
154
155           install -d ${D}${bindir}/
156           install -m 0755 ${WORKDIR}/startnetbooklauncher ${D}${bindir}/
157           install -m 0755 ${WORKDIR}/startmmenu ${D}${bindir}/
158           install -m 0755 ${WORKDIR}/startpmenu ${D}${bindir}/
159           install -m 0755 ${WORKDIR}/stopmmenu ${D}${bindir}/
160 }
161
162 PACKAGE_ARCH = "${MACHINE_ARCH}"
163
164 FILES_${PN} += "${prefix} ${datadir}"