pandora-tasks: Rearranged so that opkg shouldn't go crazy.
[openpandora.oe.git] / recipes / pandora-system / pandora-scripts-wifi.bb
1 DESCRIPTION = "Scripts to support system options on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 RDEPENDS = "pandora-scripts"
7
8 PR = "r1"
9
10 SRC_URI = " \
11           file://op_wifi.sh \
12           file://op_wifi.pnd \  
13           file://nettool.pnd \
14 "
15
16 do_install() {
17           install -d ${D}${prefix}/pandora/scripts/
18           install -m 0755 ${WORKDIR}/op_wifi.sh ${D}${prefix}/pandora/scripts/
19
20           install -d ${D}${prefix}/pandora/apps/
21           install -m 0755 ${WORKDIR}/op_wifi.pnd ${D}${prefix}/pandora/apps/
22
23           install -d ${D}${prefix}/pandora/mmenu/
24           install -m 0755 ${WORKDIR}/nettool.pnd ${D}${prefix}/pandora/mmenu/
25 }
26
27 PACKAGE_ARCH = "${MACHINE_ARCH}"
28
29 FILES_${PN} += "${prefix} ${datadir}"