pandora-pndstore: New recipe for adding Tempels PNDStore to the OS
[openpandora.oe.git] / recipes / pandora-system / pandora-pndstore.bb
1 DESCRIPTION = "Support for the PND format in Pandora images (lib, daemon, init script etc.)"
2 LICENSE = "lGPL"
3
4 PR = "r1"
5
6 SRC_URI = " \
7           git://github.com/Tempel/PNDstore.git;protocol=git;branch=master \
8           file://_ctypes.so \
9           file://op_pndstore.png \   
10           file://op_pndstore.desktop \
11 "
12
13 SRCREV = "af118e0619e58716ef58"
14
15 do_install() {
16           install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/
17           install -m 0775 ${WORKDIR}/PNDStore ${D}${prefix}/pandora/scripts/pndstore/PNDStore
18           install -m 0775 ${WORKDIR}/pndst ${D}${prefix}/pandora/scripts/pndstore/pndst
19           install -m 0644 ${WORKDIR}/README.rst ${D}${prefix}/pandora/scripts/pndstore/README.rst
20
21           install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui 
22           install -m 0775 ${WORKDIR}/pndstore_gui/PNDstore.glade ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/PNDstore.glade
23           install -m 0775 ${WORKDIR}/pndstore_gui/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_gui/__init__.py
24             
25           install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core
26           install -m 0775 ${WORKDIR}/pndstore_core/__init__.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/__init__.py
27           install -m 0775 ${WORKDIR}/pndstore_core/database_update.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/database_update.py
28           install -m 0775 ${WORKDIR}/pndstore_core/libpnd.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/libpnd.py
29           install -m 0775 ${WORKDIR}/pndstore_core/options.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/options.py
30           install -m 0775 ${WORKDIR}/pndstore_core/packages.py ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/packages.py
31
32           install -d 0775 ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg
33           install -m 0775 ${WORKDIR}/pndstore_core/cfg/default.cfg ${D}${prefix}/pandora/scripts/pndstore/pndstore_core/cfg/default.cfg
34
35           install -d ${D}${datadir}/applications/
36           install -m 0644 ${WORKDIR}/op_pndstore.desktop ${D}${datadir}/applications/
37
38           install -d ${D}${prefix}/share/pixmaps/
39           install -m 0644 ${WORKDIR}/op_pndstore.png ${D}${datadir}/share/pixmaps/
40
41 }