task-pandora-xfce: Removed e2fsprogs-tune2fs (no provider for it?)
[openpandora.oe.git] / recipes / pandora-system / pandora-pndstore.bb
1 DESCRIPTION = "Download and upgrade PND packages."
2 LICENSE = "LGPL"
3
4 PR = "r8"
5
6 SRC_URI = " \
7           git://github.com/Tempel/PNDstore.git;protocol=git;branch=master \
8           file://_ctypes.so \
9           file://op_pndstore.desktop \
10 "
11
12 SRCREV = "4c8a5ccf084c06994f50"
13
14 S = "${WORKDIR}/git"
15
16 inherit distutils
17
18 do_install_append() {
19
20       # A stop-gap fix to the ctypes bug.
21       # This can be removed once the python-ctypes package is made to behave correctly.
22       install -Dm 0644 ${WORKDIR}/_ctypes.so ${D}/usr/lib/python2.6/lib-dynload/_ctypes.so
23         
24       install -Dm 0644 ${WORKDIR}/op_pndstore.desktop ${D}${datadir}/applications/op_pndstore.desktop 
25       install -Dm 0644 ${S}/resources/icon.png ${D}${datadir}/pixmaps/op_pndstore.png
26
27 }
28
29 PACKAGE_ARCH = "${MACHINE_ARCH}"
30
31 FILES_${PN} += "${prefix} ${datadir}"