Sync with local tree. Updates to the theme, kernel SRCREV and some tweaks to tasks...
[openpandora.oe.git] / recipes / pandora-system / pandora-matchbox-gtk-theme.bb
1 DESCRIPTION = "Matchbox window manager theme for the Pandora"
2 LICENSE = "GPL"
3 DEPENDS = "matchbox-wm"
4 SECTION = "x11/wm"
5
6 PV = "0.1"
7 PR = "r0"
8
9 PACKAGE_ARCH = "all"
10
11 #GIT HEAD
12 SRCREV = 1bd11ea0a6bacafe216bbb29492e064fc52979b0
13
14 SRC_URI = " \
15         git://git.openpandora.org/pandora-libraries.git;protocol=git;branch=master \
16 "
17
18 S = "${WORKDIR}/git"
19
20 do_install() {
21         find ${WORKDIR} -name ".git" | xargs rm -rf
22         install -d ${D}${datadir}/themes/pandora-standard/gtk-2.0
23         cp -fpPR ${S}/* ${D}${datadir}/themes/pandora-standard/
24         rm -rf ${D}${datadir}/themes/pandora-standard/patches/
25         
26         install -d ${D}${sysconfdir}/gtk-2.0
27         echo 'include "${datadir}/themes/openmoko-standard-2/gtk-2.0/gtkrc"' >> ${D}${sysconfdir}/gtk-2.0/gtkrc
28 }
29
30 CONFFILES_${PN} = "${sysconfdir}/gtk-2.0/gtkrc"
31
32 PACKAGE_ARCH = "all"
33 FILES_${PN} = "${datadir} ${sysconfdir}"