pandora-libpnd: Bump SRCREV.
[openpandora.oe.git] / recipes / pandora-system / pandora-libpnd.bb
1 DESCRIPTION = "Support for the PND format in Pandora images (lib, daemon, init script etc.)"
2 LICENSE = "lGPL"
3
4 PR = "r2"
5
6 PARALLEL_MAKE = ""
7
8 SRC_URI = " \
9           git://openpandora.org/pandora-libraries.git;protocol=git;branch=master \
10           file://rc.libpnd \
11 "
12
13 SRCREV = "335950b470d3e8ae1ddfa1cf6cbc058349dddfdc"
14
15 S = "${WORKDIR}/git"
16
17 inherit update-rc.d
18
19 TARGET_CC_ARCH += "${LDFLAGS}"
20 TARGET_CFLAGS += "-Wall -I./include"
21
22 INITSCRIPT_NAME = "libpnd-init"
23 INITSCRIPT_PARAMS = "start 30 5 2 . stop 40 0 1 6 ."
24
25 do_compile_prepend() {
26           cd ${S}/
27 }
28
29 do_compile() {
30           oe_runmake 
31           oe_runmake deploy
32 }
33
34 do_install() {
35           install -d ${D}${sysconfdir}/pandora/conf/
36           install ${S}/deployment/etc/pandora/conf/apps ${D}${sysconfdir}/pandora/conf/apps
37           install ${S}/deployment/etc/pandora/conf/desktop ${D}${sysconfdir}/pandora/conf/desktop
38
39           install -d ${D}${libdir}/
40           cp -pP ${S}/deployment/usr/lib/libpnd* ${D}${libdir}/
41 #          cp -pP ${S}/deployment/usr/lib/libpnd.so.1.0.1 ${D}${libdir}/libpnd.so.1
42 #          cp -pP ${S}/deployment/usr/lib/libpnd.a ${D}${libdir}/libpnd.a
43           
44           install -d ${D}${bindir}/
45           cp -pP ${S}/deployment/usr/bin/pndnotifyd ${D}${bindir}/pndnotifyd
46                    
47           install -d ${D}${prefix}/pandora/
48           install -d ${D}${prefix}/pandora/apps/
49 #          cp -pP ${S}/deployment/usr/pandora/apps/* ${D}${prefix}/pandora/apps
50           install -d ${D}${prefix}/pandora/scripts/
51           cp -pP ${S}/deployment/usr/pandora/scripts/* ${D}${prefix}/pandora/scripts
52           
53           install -d ${D}${sysconfdir}/init.d/
54           cp -pP ${WORKDIR}/rc.libpnd ${D}${sysconfdir}/init.d/libpnd-init
55           
56           install -d ${D}/home/root/
57           install -d ${D}${prefix}/local/share/applications/
58 }
59
60 FILES_${PN} += "${bindir} ${sbindir} ${prefix}/pandora/*"
61 FILES_${PN}-dev += "${libdir}/libpnd.a"