87d9bdbb457e0237b474fc893cd392f79ad89587
[openpandora.oe.git] / recipes / pandora-system / pandora-lcd-state.bb
1 DESCRIPTION = "Save and restore the brightness and gamma state on shutdown / startup"
2 LICENSE = "GPLv2"
3
4 COMPATIBLE_MACHINE = "omap3-pandora"
5
6 PR = "r0"
7 inherit update-rc.d
8
9 INITSCRIPT_NAME = "pandora-lcd-state"
10 INITSCRIPT_PARAMS = "start 39 S . stop 31 0 1 6 ."
11
12 SRC_URI = " \
13           file://rc.pandora-lcd-state \
14           file://gamma.state \
15           file://brightness.state \
16 "
17
18 do_install() {
19           install -d ${D}${sysconfdir}/init.d/
20           install -m 0755 ${WORKDIR}/rc.pandora-lcd-state ${D}${sysconfdir}/init.d/pandora-lcd-state
21           install -d ${D}${sysconfdir}/pandora/conf/
22           install -m 0644 ${WORKDIR}/gamma.state ${D}${sysconfdir}/pandora/conf/gamma.state
23           install -m 0644 ${WORKDIR}/brightness.state ${D}${sysconfdir}/pandora/conf/brightness.state
24 }
25
26 PACKAGE_ARCH = "${MACHINE_ARCH}"
27
28 FILES_${PN} += "${prefix} ${datadir}"