Bumped first-run-wizard
[openpandora.oe.git] / recipes / pandora-system / pandora-first-run-wizard.bb
1 DESCRIPTION = "Scripts to support the first run wizard on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 DEPENDS = "hsetroot zenity dbus"
5 RDEPENDS = "hsetroot zenity dbus pandora-wallpaper-official tslib tslib-calibrate pandora-skel xmodmap"
6
7 COMPATIBLE_MACHINE = "omap3-pandora"
8
9 PR = "r22"
10
11 SRC_URI = " \
12           file://first-run-wizard.sh \
13           file://op_startup.sh \
14           file://rc.firstrun \          
15 "
16
17 inherit update-rc.d
18
19 INITSCRIPT_NAME = "oprun-init"
20 INITSCRIPT_PARAMS = "start 29 2 3 4 5 . stop  29 2 3 4 5 ."
21
22 do_install() {         
23           install -d ${D}${prefix}/pandora/scripts/
24           install -m 0755 ${WORKDIR}/first-run-wizard.sh ${D}${prefix}/pandora/scripts/
25           install -m 0755 ${WORKDIR}/op_startup.sh ${D}${prefix}/pandora/scripts/
26
27           install -d ${D}${sysconfdir}/init.d/
28           install -m 0755 ${WORKDIR}/rc.firstrun ${D}${sysconfdir}/init.d/oprun-init
29
30           install -d ${D}${sysconfdir}/pandora/          
31 }
32
33 PACKAGE_ARCH = "${MACHINE_ARCH}"
34
35 FILES_${PN} += "${prefix} ${sysconfdir}"