pandora-first-run-wizard: Update recipe and scripts (WIP).
[openpandora.oe.git] / recipes / pandora-system / pandora-first-run-wizard.bb
1 DESCRIPTION = "Scripts to support the first run wizard on the OpenPandora."
2 LICENSE = "GPLV2"
3
4 DEPENDS = "hsetroot zenity dbus"
5 RDEPENDS = "hsetroot zenity dbus"
6
7 COMPATIBLE_MACHINE = "omap3-pandora"
8
9 PR = "r5"
10
11 SRC_URI = " \
12           file://first-run-wizard.sh \
13           file://op_startup.sh \
14           file://rc.firstrun \
15           file://op_default.png \          
16 "
17
18 inherit update-rc.d
19
20 INITSCRIPT_NAME = "oprun-init"
21 INITSCRIPT_PARAMS = "start 29 2 3 4 5 . stop  29 2 3 4 5 ."
22
23 do_install() {         
24           install -d ${D}${prefix}/pandora/scripts/
25           install -m 0755 ${WORKDIR}/first-run-wizard.sh ${D}${prefix}/pandora/scripts/
26           install -m 0755 ${WORKDIR}/op_startup.sh ${D}${prefix}/pandora/scripts/
27
28           install -d ${D}${sysconfdir}/init.d/
29           install -m 0755 ${WORKDIR}/rc.firstrun ${D}${sysconfdir}/init.d/oprun-init
30
31           install -d ${D}${datadir}/backgrounds/
32           install -m 0666 ${WORKDIR}/op_default.png ${D}${datadir}/backgrounds/
33 }
34
35 PACKAGE_ARCH = "${MACHINE_ARCH}"
36
37 FILES_${PN} += "${prefix} ${sysconfdir}"