Update tree with local changes. Disable WiLink4 drivers in the image and enable the...
[openpandora.oe.git] / recipes / pandora-system / pandora-firmware.bb
1 DESCRIPTION = "Install binary firmware for Bluetooth and WiFi into the image."
2 LICENSE = "proprietary-binary"
3 RRECOMMENDS_${PN} = "kernel-module-firmware-class"
4 PR = "r5"
5
6 SRC_URI = " \
7         file://brf6300.bin \
8         file://wl1251-fw.bin \
9         file://wl1251-nvs.bin \
10 "
11
12 SUMMARY = "This is required to support the Bluetooth and WiFi modules on the Pandora"
13 S = "${WORKDIR}"
14
15 do_install() {
16         install -d ${D}/lib/firmware
17         install -m 0644 ${S}/brf6300.bin ${S}/wl1251-fw.bin ${S}/wl1251-nvs.bin ${D}/lib/firmware/
18 }
19
20 PACKAGE_ARCH = "${MACHINE_ARCH}"
21
22 FILES_${PN} += "/lib/firmware"
23
24 COMPATIBLE_MACHINE = "omap3-pandora"