3cf41d9e57f19ffe5e835e8c8e9bb1350ebff550
[openpandora.oe.git] / recipes / pandora-system / pandora-configtray-wifi.bb
1 DESCRIPTION = "A tray applet to change various Pandora-related settings"
2
3 PR = "r1"
4
5 PARALLEL_MAKE = ""
6 DEPENDS = "gtk+"
7
8 inherit pkgconfig
9
10 SRC_URI = " \
11           git://github.com/slaeshjag/pandora-configbutton.git;protocol=git;branch=master \
12           file://wifi.png \
13 "
14
15 SRCREV = "8ce849c5c37f0e6bc8c48b6e771dbd75bdcbf78f"
16
17 S = "${WORKDIR}/git"
18
19 # disable environment-overrides
20 EXTRA_OEMAKE = "MAKEFLAGS="
21
22 do_install() {
23         install -d ${D}${bindir}/
24         install -m 0755 ${S}/configbutton ${D}${bindir}/
25         install -d ${D}${datadir}/configbutton/
26         install -m 0644 ${S}/plugin/bin/wifi.so ${D}${datadir}/configbutton/
27         install -d ${D}${prefix}/share/icons/pandora/
28         install -m 0644 ${WORKDIR}/wifi.png ${D}${prefix}/share/icons/pandora/
29 }
30
31 FILES_${PN} += "${prefix} ${datadir}"