omap3-pandora-kernel: Bump SRCREV for 2.6.27 kernel.
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 # ----- Revision 2 Boards -----
9
10 #GIT HEAD for Rev2 - Same as Rev3 without Batt Fuel Guage and Nub/Button changes.
11
12 #SRCREV = "45dce3afbd5c2d2af899ae7e7a107d01a5c15558"
13
14 #SRC_URI = " \
15 #           git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=rev2 \
16 #"
17
18 # -----------------------------
19
20
21 # ----- Revision 3 > Boards -----
22
23 #GIT HEAD for Rev3 > (i.e. Shipping units) - Will run on Rev2 boards without Nubs and an incorrect Start button.
24
25 SRCREV = "b7075725f109114e144c5534cd519ffa2b9780d9"
26
27 SRC_URI = " \
28            git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
29 "          
30
31 # -------------------------------
32
33 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
34
35 SRC_URI_append = " \
36            file://defconfig \
37            file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
38            file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
39            file://no-empty-flash-warnings.patch;patch=1 \
40            file://oprofile-0.9.3.armv7.diff;patch=1 \
41            file://no-cortex-deadlock.patch;patch=1 \
42            file://read_die_ids.patch;patch=1 \
43            file://fix-install.patch;patch=1 \
44            file://musb-dma-iso-in.eml;patch=1 \
45            file://musb-support-high-bandwidth.patch.eml;patch=1 \
46            file://mru-fix-timings.diff;patch=1 \
47            file://mru-fix-display-panning.diff;patch=1 \
48            file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
49            file://mru-improve-pixclock-config.diff;patch=1 \
50            file://mru-make-video-timings-selectable.diff;patch=1 \
51            file://mru-enable-overlay-optimalization.diff;patch=1 \
52            file://musb-fix-ISO-in-unlink.diff;patch=1 \
53            file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
54            file://musb-fix-endpoints.diff;patch=1 \
55            file://dvb-fix-dma.diff;patch=1 \
56            file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
57            file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
58            file://sitecomwl168-support.diff;patch=1 \
59            file://musb-rxtx.patch;patch=1 \
60            file://0001-SDIO-patches-to-put-some-card-into-into-platform-dev.patch;patch=1 \
61            file://0002-Add-a-very-basic-platform-driver-module-to-bring-up-.patch;patch=1 \
62            file://0003-Remove-old-msm_wifi-hack-as-the-temp-platform-driver.patch;patch=1 \
63 "
64         
65 S = "${WORKDIR}/git"