Sync with local tree. Updates to the theme, kernel SRCREV and some tweaks to tasks...
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 #GIT HEAD
9 SRCREV = "462fa3321de7a3b8646c195130600af296b5e117"
10
11 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
12 PR = "r1.8"
13
14 SRC_URI = " \
15         git://openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
16         file://defconfig \
17         file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
18         file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
19         file://no-empty-flash-warnings.patch;patch=1 \
20         file://oprofile-0.9.3.armv7.diff;patch=1 \
21         file://no-cortex-deadlock.patch;patch=1 \
22         file://read_die_ids.patch;patch=1 \
23         file://fix-install.patch;patch=1 \
24         file://musb-dma-iso-in.eml;patch=1 \
25         file://musb-support-high-bandwidth.patch.eml;patch=1 \
26         file://mru-fix-timings.diff;patch=1 \
27         file://mru-fix-display-panning.diff;patch=1 \
28         file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
29         file://mru-improve-pixclock-config.diff;patch=1 \
30         file://mru-make-video-timings-selectable.diff;patch=1 \
31         file://mru-enable-overlay-optimalization.diff;patch=1 \
32         file://musb-fix-ISO-in-unlink.diff;patch=1 \
33         file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
34         file://musb-fix-endpoints.diff;patch=1 \
35         file://dvb-fix-dma.diff;patch=1 \
36         file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
37         file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
38         file://sitecomwl168-support.diff;patch=1 \
39 #       file://pvr/pvr-add.patch;patch=1 \
40         file://pvr/dispc.patch;patch=1 \
41 #       file://pvr/nokia-TI.diff;patch=1 \
42 "
43         
44 S = "${WORKDIR}/git"