Rename packages to recipes to sync the overlay with mainline oe.dev
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 #GIT HEAD 8th March
9 SRCREV = "6659d29395831bf5d6e589b288bfc3faf2096d2f"
10
11 #GIT HEAD 7th Feb
12 #SRCREV = "98000fc8f72fd9d35ae2fea0528e756febbe0916"
13
14 #MMC3/WiFi commit
15 #SRCREV = "33280e83ef2260f8f6ba01345c5d75a9d97a49c0"
16
17 #Pre MMC3
18 #SRCREV = "fdb85aeee5f1993265bf46d4dfeae32a3fb8b886"
19
20 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
21 PR = "r1.6"
22
23 SRC_URI = " \
24         git://openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
25         file://defconfig \
26         file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
27         file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
28         file://no-empty-flash-warnings.patch;patch=1 \
29         file://oprofile-0.9.3.armv7.diff;patch=1 \
30         file://no-cortex-deadlock.patch;patch=1 \
31         file://read_die_ids.patch;patch=1 \
32         file://fix-install.patch;patch=1 \
33         file://musb-dma-iso-in.eml;patch=1 \
34         file://musb-support-high-bandwidth.patch.eml;patch=1 \
35         file://mru-fix-timings.diff;patch=1 \
36         file://mru-fix-display-panning.diff;patch=1 \
37         file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
38         file://mru-add-clk-get-parent.diff;patch=1 \
39         file://mru-improve-pixclock-config.diff;patch=1 \
40         file://mru-make-video-timings-selectable.diff;patch=1 \
41         file://mru-enable-overlay-optimalization.diff;patch=1 \
42         file://musb-fix-ISO-in-unlink.diff;patch=1 \
43         file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
44         file://musb-fix-endpoints.diff;patch=1 \
45         file://dvb-fix-dma.diff;patch=1 \
46         file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
47         file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
48         file://sitecomwl168-support.diff;patch=1 \
49 #       file://pvr/pvr-add.patch;patch=1 \
50         file://pvr/dispc.patch;patch=1 \
51 #       file://pvr/nokia-TI.diff;patch=1 \
52 "
53         
54 S = "${WORKDIR}/git"