omap3-pandora-kernel: Add latest AUFS2 and SquashFS to the kernel 'in tree' so Squash...
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 SRCREV = "abd422d7c820719eb12123ba08fab925e6f9b40c"
9
10 SRC_URI = " \
11            git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
12 "          
13
14 # -------------------------------
15
16 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
17
18 SRC_URI_append = " \
19            file://defconfig \
20            file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
21            file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
22            file://no-empty-flash-warnings.patch;patch=1 \
23            file://oprofile-0.9.3.armv7.diff;patch=1 \
24            file://no-cortex-deadlock.patch;patch=1 \
25            file://read_die_ids.patch;patch=1 \
26            file://fix-install.patch;patch=1 \
27 #           file://musb-dma-iso-in.eml;patch=1 \
28 #           file://musb-support-high-bandwidth.patch.eml;patch=1 \
29            file://mru-fix-timings.diff;patch=1 \
30            file://mru-fix-display-panning.diff;patch=1 \
31            file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
32            file://mru-improve-pixclock-config.diff;patch=1 \
33            file://mru-make-video-timings-selectable.diff;patch=1 \
34            file://mru-enable-overlay-optimalization.diff;patch=1 \
35 #           file://musb-fix-ISO-in-unlink.diff;patch=1 \
36 #           file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
37 #           file://musb-fix-endpoints.diff;patch=1 \
38            file://dvb-fix-dma.diff;patch=1 \
39            file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
40            file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
41            file://sitecomwl168-support.diff;patch=1 \
42            file://musb-rxtx.patch;patch=1 \
43            file://0001-SDIO-patches-to-put-some-card-into-into-platform-dev.patch;patch=1 \
44            file://0002-Add-a-very-basic-platform-driver-module-to-bring-up-.patch;patch=1 \
45            file://0003-Remove-old-msm_wifi-hack-as-the-temp-platform-driver.patch;patch=1 \
46 "
47
48 # Temp Keypad Patches for FN.
49
50 SRC_URI_append = " \
51            file://keypad/0001-input-remove-old-twl4030keypad-to-replace-it-with-ma.patch;patch=1 \
52            file://keypad/0002-Input-add-support-for-generic-GPIO-based-matrix-keyp.patch;patch=1 \
53            file://keypad/0003-Input-matrix_keypad-make-matrix-keymap-size-dynamic.patch;patch=1 \
54            file://keypad/0004-Input-matrix-keypad-add-function-to-build-device-key.patch;patch=1 \
55            file://keypad/0005-Input-add-twl4030_keypad-driver.patch;patch=1 \
56            file://keypad/0006-input-hacks-updates-for-mainline-twl4030-driver.patch;patch=1 \
57            file://keypad/0007-some-hackish-Fn-handling-for-testing.patch;patch=1 \           
58 "       
59
60 # SquashFS 4 Patches
61
62 SRC_URI_append = " \
63            file://squashfs/0006-SquashFS-Backport-SquashFS4-to-our-2.6.27-tree.patch;patch=1 \
64 "           
65
66 # AUFS2 Patches - Used by ausf2-27 recipe to build as a module.
67
68 SRC_URI_append = " \
69            file://aufs2/0007-AUFS2-Add-latest-AUFS2-in-tree-code-for-2.6.27.patch;patch=1 \
70 "           
71
72 S = "${WORKDIR}/git"