1772e6eda1fdf5fb09f22be656df375bad16bdf2
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel_2.6.27-pandora.bb
1 require linux.inc
2
3 DESCRIPTION = "2.6.27 Linux kernel for the Pandora handheld console"
4 KERNEL_IMAGETYPE = "uImage"
5
6 COMPATIBLE_MACHINE = "omap3-pandora"
7
8 #GIT HEAD for Rev2
9 SRCREV = "7aeecd01683d0b1087122d442346b2945c480cf7"
10
11 #Rev2
12 SRC_URI = " \
13            git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=pandora-27-omap1 \
14 "
15
16
17 #GIT HEAD for Rev3
18 #SRCREV = "4162fb142cd8d5a435b69fa44d6b1eec349420c9"
19
20 #Rev3
21 #SRC_URI = " \
22 #           git://git.openpandora.org/pandora-kernel.git;protocol=git;branch=rev3 \
23 #"          
24
25 PV = "2.6.27-pandora+${PR}+git${SRCREV}"
26
27 SRC_URI_append = " \
28            file://defconfig \
29            file://0001-Add-EHCI-patch-suggested-by-Steven-Kipisz.patch;patch=1 \
30            file://0002-Add-missing-define-to-EHCI-OMAP.c.patch;patch=1 \
31            file://no-empty-flash-warnings.patch;patch=1 \
32            file://oprofile-0.9.3.armv7.diff;patch=1 \
33            file://no-cortex-deadlock.patch;patch=1 \
34            file://read_die_ids.patch;patch=1 \
35            file://fix-install.patch;patch=1 \
36            file://musb-dma-iso-in.eml;patch=1 \
37            file://musb-support-high-bandwidth.patch.eml;patch=1 \
38            file://mru-fix-timings.diff;patch=1 \
39            file://mru-fix-display-panning.diff;patch=1 \
40            file://mru-make-dpll4-m4-ck-programmable.diff;patch=1 \
41            file://mru-improve-pixclock-config.diff;patch=1 \
42            file://mru-make-video-timings-selectable.diff;patch=1 \
43            file://mru-enable-overlay-optimalization.diff;patch=1 \
44            file://musb-fix-ISO-in-unlink.diff;patch=1 \
45            file://musb-fix-multiple-bulk-transfers.diff;patch=1 \
46            file://musb-fix-endpoints.diff;patch=1 \
47            file://dvb-fix-dma.diff;patch=1 \
48            file://0001-Removed-resolution-check-that-prevents-scaling-when.patch;patch=1 \
49            file://0001-Implement-downsampling-with-debugs.patch;patch=1 \
50            file://sitecomwl168-support.diff;patch=1 \
51 #       file://pvr/dispc.patch;patch=1 \
52            file://musb-rxtx.patch;patch=1 \
53 #       file://0001-implement-TIF_RESTORE_SIGMASK-support-and-enable-the.patch;patch=1 \
54            file://0001-SDIO-patches-to-put-some-card-into-into-platform-dev.patch;patch=1 \
55 "
56         
57 S = "${WORKDIR}/git"