omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux / omap3-pandora-kernel2_3.2-pandora.bb
1 DESCRIPTION = "3.2 Linux kernel for the Pandora handheld console"
2 SECTION = "kernel"
3 LICENSE = "GPLv2"
4 COMPATIBLE_MACHINE = "omap3-pandora"
5 PACKAGE_ARCH = "${MACHINE_ARCH}"
6
7 PR = "r31"
8
9 # we already build 2.6 kernel using OE infrastructure, and
10 # as we don't know how to build another one into the same image
11 # (especially out-of-tree modules), we just package manually prebuilt one
12 # git://git.openpandora.org/pandora-kernel.git , branch pandora-3.2
13 # commit: 44603ffcdd761ef8579e268fe8fd1cf6f27ffe05
14 # out-of-tree modules are built from:
15 # http://git.openpandora.org/cgi-bin/gitweb.cgi?p=sgx.git
16 # http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_modules.tar.bz2
17 SRC_URI = "http://notaz.gp2x.de/misc/pnd/oe_rootfs_extra_${PR}.tar.bz2"
18
19 S = "${WORKDIR}"
20
21 do_install() {
22   cp -a ${S}/boot ${D}/
23   cp -a ${S}/lib ${D}/
24   rm -f ${D}/lib/modules/*/modules.dep*
25
26   # dupes from other OE packages..
27   rm -rf ${D}/lib/firmware/vicam
28   rm -rf ${D}/lib/firmware/ttusb-budget
29 }
30
31 PACKAGES =+ "linux-firmware-media"
32
33 FILES_${PN} = "boot lib"
34 FILES_linux-firmware-media = "lib/firmware"
35
36 pkg_postinst_${PN} () {
37   # this will cause depmod to be run on next boot
38   rm -f /lib/modules/`uname -r`/modules.dep
39   sync
40
41   if ! grep -q '[[:blank:]]/[[:blank:]]*ubifs' /proc/mounts; then
42     for dir in `ls -d /media/*boot* 2> /dev/null` `ls -d /media/*BOOT* 2> /dev/null`; do
43       test -e $dir/uImage && oldkernel=$dir/uImage
44       test -e $dir/uImage-3 && oldkernel=$dir/uImage-3
45     done
46
47     if test -n "$oldkernel"; then
48       cp /boot/uImage-3 $oldkernel
49       msg="Updated kernel has beed copied to ${oldkernel}. \
50 If this location is wrong, copy /boot/uImage-3 to the location \
51 where your kernel is booted from (usually set in boot.txt / autoboot.txt)."
52     else
53       msg="The kernel in /boot/uImage-3 has been updated. You need to \
54 copy it to the location where kernel is booted from (usually set in \
55 boot.txt / autoboot.txt) or the system might not start after reboot."
56     fi
57     sync
58     if test -n "$DISPLAY"; then
59       zenity --info --text "$msg"
60     else
61       echo "=================================="
62       echo "$msg"
63       sleep 5
64     fi
65   fi
66 }
67
68 PACKAGE_STRIP = "no"
69 SRC_URI[md5sum] = "8aade2cc872c833cc91ed443a4637b70"
70 SRC_URI[sha256sum] = "bb1ffe26500998db005a7bf60933a14ea64052534576bd442bc97e410734c656"