omap3-pandora-kernel2: update
[openpandora.oe.git] / recipes / linux-firmware / linux-firmware-pnd_git.bb
1 DESCRIPTION = "Firmware files for use with Linux kernel"
2
3 PR_append = "+gitr${SRCREV}"
4 SRCREV = "7d0c7a8cfd78388d90cc784a185b19dcbdbce824"
5
6 SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git;protocol=git"
7
8 S = "${WORKDIR}/git"
9
10 do_compile() {
11         :
12 }
13
14 do_install() {
15         install -d ${D}/lib/firmware/
16         # we're too tight on space to copy all on pandora..
17         # cp -rpP * ${D}/lib/firmware/
18         cp -pP rt*.bin ${D}/lib/firmware/
19         cp -pP htc_*.fw ${D}/lib/firmware/
20         cp -pP carl9170-1.fw ${D}/lib/firmware/
21         install -d ${D}/lib/firmware/rtlwifi/
22         cp -pP rtlwifi/rtl8192cufw.bin ${D}/lib/firmware/rtlwifi/rtl8192cufw.bin
23 }
24
25 FILES_${PN} += "/lib/firmware/*"
26 PACKAGE_ARCH = "all"