pandora-xfce-image: specify IMAGE_LOGIN_MANAGER
[openpandora.oe.git] / recipes / images / pandora-xfce-image-nowifi.bb
1 # XFCE image for the Pandora handheld console
2
3 IMAGE_LINGUAS = "de-de fr-fr en-gb en-us es-es"
4
5 IMAGE_LOGIN_MANAGER = "shadow"
6
7 inherit image
8
9 PR = "r7"
10
11 export IMAGE_BASENAME = "pandora-xfce-image-nowifi"
12
13 SPLASH = "psplash-omap3pandora"
14
15 DEPENDS = "task-base"
16
17 IMAGE_INSTALL += " \
18     task-pandora-core \
19     task-pandora-xfce-nowifi \
20     ${SPLASH} \ 
21 "
22
23 IMAGE_PREPROCESS_COMMAND = "create_etc_timestamp"
24
25 # reminder: /etc/op-version is now made by recipes/pandora-system/pandora-version.bb
26
27 # HACK for different serial ports used by different kernels
28 ROOTFS_POSTPROCESS_COMMAND += "sed -i -e '/ttyS2/a ttyO2' ${IMAGE_ROOTFS}/${sysconfdir}/securetty;"
29
30 # call a script to generate flashes tools automatically
31 ROOTFS_POSTPROCESS_COMMAND += "if [ -e ${HOME}/oe_make_bootf/do.sh ]; then ${HOME}/oe_make_bootf/do.sh ${IMAGE_ROOTFS} ${DEPLOY_DIR_IMAGE}; fi;"