gtk-touchscreen-mode-enable: Add little recipe that sets this in GTKRC.
[openpandora.oe.git] / recipes / gtk / gtk-touchscreen-mode-enable.bb
1 DESCRIPTION = "Enable gtk-touchscreen-mode in gtkrc"
2
3 RDEPENDS = "gtk+"
4
5 PR = "r2"
6
7 ALLOW_EMPTY_${PN} = "1"
8 PACKAGE_ARCH = "all"
9
10 pkg_postinst() {
11 #!/bin/sh
12 mkdir -p $D${sysconfdir}/gtk-2.0
13 touch $D${sysconfdir}/gtk-2.0/gtkrc
14 sed -i /gtk-touchscreen-mode = 1/d $D${sysconfdir}/gtk-2.0/gtkrc
15 echo 'gtk-touchscreen-mode = 1' >> $D${sysconfdir}/gtk-2.0/gtkrc
16 }