pandora-libpnd: bump
[openpandora.oe.git] / recipes / f3 / f3_git.bb
1 DESCRIPTION = "F3 - Fight Flash Fraud - test real flash memory capacity"
2 LICENSE = "GPLv3"
3
4 PR = "r0"
5 PR_append = "+gitr${SRCPV}"
6
7 SRC_URI = " \
8   git://github.com/AltraMayor/f3.git;protocol=git;branch=master \
9   file://0001-allow-users-to-specify-linker-flags.patch;patch=1 \
10 "
11
12 SRCREV = "cbe8d6167a214ceec516b9ff7f0b5e1bdeb06079"
13
14 S = "${WORKDIR}/git"
15
16 do_compile() {
17         oe_runmake
18 }
19
20 do_install() {
21         install -d ${D}${bindir}/
22         install -m 0755 f3write ${D}${bindir}/
23         install -m 0755 f3read ${D}${bindir}/
24         install -d ${D}${mandir}/
25         install -m 0644 f3read.1 ${D}${mandir}/
26         ln -fs f3read.1 ${D}${mandir}/f3write.1
27 }