pandora-libpnd.bb: Bumped to latest version
[openpandora.oe.git] / recipes / branding / pandora-midori-defaults.bb
1 DESCRIPTION = "Default OpenPandora settings for the Midori web browser"
2 HOMEPAGE = "http://www.openpandora.org"
3
4 PR = "r1"
5
6 # This 'sort of ' depends on the other SKEL templates.
7 RDEPENDS = "pandora-skel"
8
9 SRC_URI = " \
10   file://accels \
11   file://config \
12   file://session.xbel \
13   file://speeddial.json \
14   file://bookmarks.xbel \
15 "
16
17 do_install() {  
18   install -d ${D}${sysconfdir}/skel/
19   install -d ${D}${sysconfdir}/skel/Applications/
20   install -d ${D}${sysconfdir}/skel/Applications/Settings/
21   install -d ${D}${sysconfdir}/skel/Applications/Settings/midori/
22
23   install -m 0644 ${WORKDIR}/accels ${D}${sysconfdir}/skel/Applications/Settings/midori/accels
24   install -m 0644 ${WORKDIR}/config ${D}${sysconfdir}/skel/Applications/Settings/midori/config
25   install -m 0644 ${WORKDIR}/session.xbel ${D}${sysconfdir}/skel/Applications/Settings/midori/session.xbel
26   install -m 0644 ${WORKDIR}/speeddial.json ${D}${sysconfdir}/skel/Applications/Settings/midori/speeddial.json
27   install -m 0644 ${WORKDIR}/bookmarks.xbel ${D}${sysconfdir}/skel/Applications/Settings/midori/bookmarks.xbel  
28 }
29
30 PACKAGE_ARCH = "${MACHINE_ARCH}"
31
32 FILES_${PN} += "${sysconfdir}"
33