android-tools: add recipe
[openpandora.oe.git] / recipes / android-tools / android-tools_4.2.2.bb
1 DESCRIPTION = "Different utilities from Android - based on the corresponding ubuntu \
2 package"
3 SECTION = "console/utils"
4 LICENSE = "Apache-2.0 GPL-2.0 BSD-2-Clause BSD-3-Clause"
5 LIC_FILES_CHKSUM = " \
6   file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10 \
7   file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6 \
8   file://${COMMON_LICENSE_DIR}/BSD-2-Clause;md5=8bef8e6712b1be5aa76af1ebde9d6378 \
9   file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9 \
10   file://${WORKDIR}/debian/copyright;md5=141efd1050596168ca05ced04e4f498b \
11 "
12
13 DEPENDS = "zlib openssl"
14 # RDEPENDS_${PN} = "${PN}-conf"
15
16 # Use same version than ubuntu does here
17 BASE_PV = "4.2.2+git20130218"
18 PV = "${BASE_PV}-3ubuntu13"
19
20 # BBCLASSEXTEND += "native"
21
22 SRC_URI = " \
23     https://launchpad.net/ubuntu/+archive/primary/+files/android-tools_${BASE_PV}.orig.tar.xz;name=source \
24     https://launchpad.net/ubuntu/+archive/primary/+files/android-tools_${PV}.debian.tar.gz;name=debian \
25     file://add_adbd.patch;patch=1 \
26     file://reboot-syscall.patch;patch=1 \
27     file://adbd-disable-client-authentication.patch;patch=1 \
28     file://disable-selinux-support.patch;patch=1 \
29 #    file://remove-libselinux.patch;patch=1 \
30 #    file://android-tools-adbd.service \
31     file://mkbootimg.mk \
32     file://sha.c \
33 "
34 S = "${WORKDIR}/android-tools"
35
36 SRC_URI[source.md5sum] = "0e653b129ab0c95bdffa91410c8b55be"
37 SRC_URI[source.sha256sum] = "9bfba987e1351b12aa983787b9ae4424ab752e9e646d8e93771538dc1e5d932f"
38 SRC_URI[debian.md5sum] = "5e409d01caf3c33fc60a2100464754ff"
39 SRC_URI[debian.sha256sum] = "320757edc8af015f40335c41dc96bf37e2d50c9f3a40a31e64264ff6e2dba5e3"
40
41 # inherit systemd
42 # SYSTEMD_SERVICE_${PN} = "android-tools-adbd.service"
43
44 # disable environment-overrides
45 EXTRA_OEMAKE = "MAKEFLAGS="
46
47 do_compile() {
48     # Setting both variables below causing our makefiles to not work with implicit make
49     # rules
50     #unset CFLAGS
51     #unset CPPFLAGS
52     #unset MAKEFLAGS
53
54     sed -i "s%^CPPFLAGS+= -I/usr/include%# we don't want to include headers from host CPPFLAGS+= -I/usr/include%g" ${WORKDIR}/debian/makefiles/ext4_utils.mk
55     sed -i 's/-lselinux//' ${WORKDIR}/debian/makefiles/ext4_utils.mk
56
57     sed -i 's/$(LDFLAGS) $(OBJS)/$(LDFLAGS) $^/' ${WORKDIR}/debian/makefiles/fastboot.mk
58     sed -i 's/-lselinux//' ${WORKDIR}/debian/makefiles/fastboot.mk
59
60     #oe_runmake -f ${WORKDIR}/debian/makefiles/adbd.mk -C ${S}/core/adbd clean
61     #oe_runmake -f ${WORKDIR}/debian/makefiles/adbd.mk -C ${S}/core/adbd
62
63     oe_runmake -f ${WORKDIR}/debian/makefiles/ext4_utils.mk -C ${S}/extras/ext4_utils clean
64     oe_runmake -f ${WORKDIR}/debian/makefiles/ext4_utils.mk -C ${S}/extras/ext4_utils
65
66     oe_runmake -f ${WORKDIR}/debian/makefiles/adb.mk -C ${S}/core/adb clean
67     oe_runmake -f ${WORKDIR}/debian/makefiles/adb.mk -C ${S}/core/adb
68
69     oe_runmake -f ${WORKDIR}/debian/makefiles/fastboot.mk -C ${S}/core/fastboot clean
70     oe_runmake -f ${WORKDIR}/debian/makefiles/fastboot.mk -C ${S}/core/fastboot
71
72     cp ${WORKDIR}/sha.c ${S}/core/mkbootimg/
73     oe_runmake -f ${WORKDIR}/mkbootimg.mk -C ${S}/core/mkbootimg clean
74     oe_runmake -f ${WORKDIR}/mkbootimg.mk -C ${S}/core/mkbootimg
75 }
76
77 do_install() {
78     install -d ${D}${bindir}
79     #install -m 0755 ${S}/core/adbd/adbd ${D}${bindir}
80     install -m 0755 ${S}/extras/ext4_utils/make_ext4fs ${D}${bindir}
81     install -m 0755 ${S}/core/adb/adb ${D}${bindir}
82     install -m 0755 ${S}/core/fastboot/fastboot ${D}${bindir}
83     install -m 0755 ${S}/core/mkbootimg/mkbootimg ${D}${bindir}
84
85     #install -d ${D}${systemd_unitdir}/system
86     #install -m 0644 ${WORKDIR}/android-tools-adbd.service ${D}${systemd_unitdir}/system
87 }
88
89 PACKAGES += " \
90 #  ${PN}-adbd \
91   ${PN}-fsutils \
92   ${PN}-adb \
93   ${PN}-fastboot \
94   ${PN}-mkbootimg \
95 "
96
97 FILES_${PN} = ""
98 #FILES_${PN}-adbd += "${bindir}/adbd"
99 FILES_${PN}-fsutils += "${bindir}/make_ext4fs"
100 FILES_${PN}-adb += "${bindir}/adb"
101 FILES_${PN}-fastboot += "${bindir}/fastboot"
102 FILES_${PN}-mkbootimg += "${bindir}/mkbootimg"