Cleanup part of my local tree to push up to git.openpandora.org. Not taking history...
[openpandora.oe.git] / packages / tasks / task-pandora-core.bb
1 DESCRIPTION = "Task file for default core/console apps in the Pandora image"
2
3 # Use this task as a base to ship all kernel modules and make sure firmware and drivers are installed for BT and WiFi.
4 # Please see metadata/openpandora.oe.git/packages/pandora-system/pandora-firmware/pandora-firmware/readme.txt for info on the hacks for firmware.
5
6 # Don't forget to bump the PR if you change it.
7
8 PR = "r1.8"
9
10 inherit task 
11
12 RDEPENDS_${PN} = "\
13         task-base-extended \
14         task-proper-tools \
15         pandora-firmware \
16         pandora-wifi pandora-wifi-tools \
17         omap3-deviceid \        
18         omap3-sgx-modules libgles-omap3 \
19         libwiimote \
20         libsdl-gfx \
21         nfs-utils nfs-utils-client \
22         i2c-tools \
23         tslib tslib-tests tslib-calibrate pointercal \
24         bash \
25         bzip2 \
26         psplash \
27         fbgrab fbset fbset-modes \
28         portmap \
29         fuse sshfs-fuse ntfs-3g \
30         file \
31         aufs \
32         socat \
33         strace \
34         python-pygame \
35         ksymoops \
36         kexec-tools \
37         minicom \
38         nano \
39         alsa-utils alsa-utils-alsactl alsa-utils-alsamixer alsa-utils-aplay \
40         openssh-scp \
41         openssh-ssh \
42         bluez4 bluez-hcidump bluez-utils \
43         wireless-tools \
44         rdesktop \
45         zip \
46         openssh-scp openssh-ssh \
47         mplayer \
48         networkmanager netm-cli \
49 "
50
51 # Make sure we install all kernel modules with the Pandora images
52 RRECOMMENDS_${PN} += "kernel-modules"
53
54 PACKAGE_ARCH = "${MACHINE_ARCH}"
55 RRECOMMENDS_${PN}_append_armv7a = " omapfbplay"