ff968e7d295f1cc2ee780f687d0ca4d05201fcb9
[openpandora.oe.git] / packages / pandora-system / pandora-wifi-tools_git.bb
1 DESCRIPTION = "Tools to support the TI1251 WiFi chip found on the Pandora - Connected via SDIO"
2 LICENSE = "GPLv2"
3
4 DEPENDS = "pandora-wifi"
5
6 PR = "r3"
7
8 # Check the include for the source location/GIT SRCREV etc.
9 require pandora-wifi.inc
10
11 SRC_URI += " \
12         file://wlan_cu_makefile.patch;patch=1 \
13 "
14
15 #
16 #make  CROSS_COMPILE=${KERNEL_PREFIX} CROSS_COMPILE=arm-none-linux-gnueabi- V=1 ARCH=arm KERNEL_DIR=/storage/file-store/Projects/Pandora/pandora-kernel.git OUTPUT_DIR=/storage/file-store/Projects/Pandora/pandora-wifi.git
17
18 do_compile_prepend() {
19         cd ${S}/sta_dk_4_0_4_32/CUDK/CLI/
20 }
21
22 do_install() {
23         install -d ${D}${bindir}
24         install -m 0755 ${S}/wlan_cu ${D}${bindir}
25 #       install -m 0755 ${S}/tiwlan_loader ${D}${bindir}
26 }
27
28 FILES_${PN} = "/usr/bin/wlan_cu /usr/bin/tiwlan_loader"
29